<!DOCTYPE html><html class=no-js lang=en-US prefix="og: https://ogp.me/ns# fb: https://ogp.me/ns/fb# article: https://ogp.me/ns/article#"><head><style>img.lazy{min-height:1px}</style><link rel=preload href=https://cdn1.fishduck.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js?x88222 as=script><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1.0"><link rel=pingback href=https://fishduck.com/xmlrpc.php><title>Is Isaac Townsend a Future OLB STAR for the Ducks? | FishDuck</title><meta name=description content="In 2018, the NCAA proposed that redshirted players could participate in up to four games in a season without burning up a year of collegiate athletic&#8230;"><link rel=canonical href=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/ ><link rel=alternate type=application/rss+xml title="FishDuck &raquo; Feed" href=https://fishduck.com/feed/ ><link rel=alternate type=application/rss+xml title="FishDuck &raquo; Comments Feed" href=https://fishduck.com/comments/feed/ ><link rel=alternate type=application/rss+xml title="FishDuck &raquo; Is Isaac Townsend a Future OLB STAR for the Ducks? Comments Feed" href=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/feed/ ><link rel=stylesheet href=https://cdn.fishduck.com/wp-content/cache/minify/6d0e6.css?x88222 media=all><link rel=stylesheet id=wp-editor-font-css  href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&#038;ver=5.4.2' type=text/css media=all><link rel=stylesheet href=https://cdn.fishduck.com/wp-content/cache/minify/ecd9c.css?x88222 media=all><style id=dcl-front-style-dummy-inline-css>#dcl_btn_container{text-align:center;margin-top:10px;margin-bottom:10px}</style><link rel=stylesheet href=https://cdn.fishduck.com/wp-content/cache/minify/b0144.css?x88222 media=all> <script src='https://cdn1.fishduck.com/wp-includes/js/jquery/jquery.js?x88222'></script> <script src='https://cdn1.fishduck.com/wp-includes/js/jquery/jquery-migrate.min.js?x88222'></script> <link rel=https://api.w.org/ href=https://fishduck.com/wp-json/ ><link rel=alternate type=application/json+oembed href="https://fishduck.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffishduck.com%2F2020%2F06%2Fis-isaac-townsend-a-future-olb-star-for-the-ducks%2F"><link rel=alternate type=text/xml+oembed href="https://fishduck.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffishduck.com%2F2020%2F06%2Fis-isaac-townsend-a-future-olb-star-for-the-ducks%2F&#038;format=xml">  <script>_atrk_opts={atrk_acct:"O+dIk1ao6C52O7",domain:"fishduck.com",dynamic:true};(function(){var as=document.createElement('script');as.type='text/javascript';as.async=true;as.src="https://certify-js.alexametrics.com/atrk.js";var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as,s);})();</script> <noscript><img class=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src="https://certify.alexametrics.com/atrk.gif?account=O+dIk1ao6C52O7" style=display:none height=1 width=1 alt></noscript><meta property=fb:pages content=266952793316048> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-24966687-1"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-24966687-1');</script> <style>@media screen{.printfriendly{position:relative;z-index:1000;margin:12px 12px 12px 12px}.printfriendly a, .printfriendly a:link, .printfriendly a:visited, .printfriendly a:hover, .printfriendly a:active{font-weight:600;cursor:pointer;text-decoration:none;border:none;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;outline:none;font-size:14px;color:#6D9F00}.printfriendly.pf-alignleft{float:left}.printfriendly.pf-alignright{float:right}.printfriendly.pf-aligncenter{display:flex;align-items:center;justify-content:center}}@media print{.printfriendly{display:none}}</style><style>#related_posts_thumbnails li{border-right:1px solid #ddd;background-color:#fff}#related_posts_thumbnails li:hover{background-color:#eee}.relpost_content{font-size:12px;color:#333}.relpost-block-single{background-color:#fff;border-right:1px solid  #ddd;border-left:1px solid  #ddd;margin-right:-1px}.relpost-block-single:hover{background-color:#eee}</style><meta name=generator content="WPSSO Core 7.10.1/L*"><meta name=generator content="WPSSO RRSSB 4.4.2/S"><meta name=generator content="WPSSO UM 2.14.2/S"><link rel=shortlink href="https://fishduck.com/?p=179535"><meta property=fb:app_id content=146912038807686><meta property=og:type content=article><meta property=og:url content=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/ ><meta property=og:locale content=en_US><meta property=og:site_name content=FishDuck><meta property=og:title content="Is Isaac Townsend a Future OLB STAR for the Ducks?"><meta property=og:description content="In 2018, the NCAA proposed that redshirted players could participate in up to four games in a season without burning up a year of collegiate athletic..."><meta property=og:updated_time content=2020-06-28T07:23:47+00:00><meta property=og:image content=https://cdn.fishduck.com/wp-content/uploads/2020/06/rosebtown-600x400.jpeg?x88222><meta property=og:image:width content=600><meta property=og:image:height content=400><meta property=article:publisher content=https://www.facebook.com/FishDuckOnline><meta property=article:published_time content=2020-06-28T09:05:10+00:00><meta property=article:modified_time content=2020-06-28T07:23:47+00:00><meta property=article:tag content="Isaac Townsend"><meta property=article:tag content="Oregon Ducks"><meta property=article:tag content="Oregon Ducks Football"><meta property=article:tag content="Oregon Ducks Recruiting"><meta property=article:tag content="Oregon Football Redshirt Freshmen"><meta name=twitter:domain content=fishduck.com><meta name=twitter:site content=@fishduckdotcom><meta name=twitter:title content="Is Isaac Townsend a Future OLB STAR for the Ducks?"><meta name=twitter:description content="In 2018, the NCAA proposed that redshirted players could participate in up to four games in a season without burning up a year of collegiate athletic..."><meta name=twitter:card content=summary_large_image><meta name=twitter:image content="https://cdn2.fishduck.com/wp-content/uploads/2020/06/rosebtown-scaled-300x300-cropped.jpeg?x88222"><link itemprop=url href=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/ ><meta itemprop=name content="Is Isaac Townsend a Future OLB STAR for the Ducks?"><meta itemprop=description content="In 2018, the NCAA proposed that redshirted players could participate in up to four games in a season without burning up a year of collegiate athletic..."><link itemprop=image href=https://cdn3.fishduck.com/wp-content/uploads/2020/06/rosebtown-800x533.jpeg?x88222><meta name=thumbnail content=https://cdn3.fishduck.com/wp-content/uploads/2020/06/rosebtown-scaled-600x315-cropped.jpeg?x88222><style>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</style><link rel=icon href=https://cdn.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-32x32.png sizes=32x32><link rel=icon href=https://cdn2.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-192x192.png sizes=192x192><link rel=apple-touch-icon href=https://cdn2.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-180x180.png?x88222><meta name=msapplication-TileImage content=https://cdn2.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-270x270.png?x88222><style id=wp-custom-css>#spMainContainer #spAck{display:none}#wppb-submit,#recover_password,#edit_profile,#register{color:#000}</style><style id=x-generated-css>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</style><link rel=stylesheet href="//fonts.googleapis.com/css?family=Lato:400,400i,700,700i&#038;subset=latin,latin-ext&#038;display=auto" type=text/css media=all data-x-google-fonts></head><body class="post-template-default single single-post postid-179535 single-format-standard x-integrity x-integrity-light x-full-width-layout-active x-full-width-active pro-v3_1_2 cornerstone-v4_1_2"><div id=x-root class=x-root ><div id=x-site class="x-site site" ><header class=x-masthead role=banner ><div class="e154983-1 x-bar x-bar-top x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xl x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154983-1&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;4em&quot;} ><div class="e154983-1 x-bar-content"><div class="e154983-2 x-bar-container" ><ul class="e154983-3 x-menu x-menu-inline  x-hide-xs" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154985" id=menu-item-154985 > <a class="e154983-3 x-anchor x-anchor-menu-item" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154986" id=menu-item-154986 > <a class="e154983-3 x-anchor x-anchor-menu-item" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154987" id=menu-item-154987 > <a class="e154983-3 x-anchor x-anchor-menu-item" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154988" id=menu-item-154988 > <a class="e154983-3 x-anchor x-anchor-menu-item" tabindex=0 title=Contact href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a></li></ul><div class="e154983-4 x-mod-container" > <a class="e154983-4 x-anchor x-anchor-toggle" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-4 aria-controls=e154983-4-dropdown aria-expanded=false aria-haspopup=true aria-label="Toggle Dropdown Content" ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-s=&#xf002; ></i></span></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-b_c" aria-hidden=true > <span></span> </span> </a><div id=e154983-4-dropdown class="e154983-4 x-dropdown" data-x-stem data-x-stem-top data-x-toggleable=e154983-4 aria-hidden=true ><form class="e154983-4 x-search" data-x-search={&quot;search&quot;:true} action=https://fishduck.com/ method=get ><label class=visually-hidden for=s-e154983-4 >Search</label><input id=s-e154983-4 class=x-search-input type=search name=s tabindex=0 placeholder=Search> <button class="x-search-btn x-search-btn-submit" type=button data-x-search-submit tabindex=0 ><span class=visually-hidden>Submit</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><circle fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 cx=10 cy=10 r=9 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=22 y1=22 x2=16.4 y2=16.4 stroke-linejoin=miter /></svg></button> <button class="x-search-btn x-search-btn-clear" type=button data-x-search-clear tabindex=0 ><span class=visually-hidden>Clear</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=5 x2=5 y2=19 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=19 x2=5 y2=5 stroke-linejoin=miter /></svg></button></form></div></div></div><div class="e154983-5 x-bar-container" > <a class="e154983-6 x-anchor x-anchor-toggle  x-hide-lg x-hide-md x-hide-sm x-hide-xl" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-6 ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <span class="x-toggle x-toggle-grid x-graphic-toggle" aria-hidden=true > <span class=x-toggle-grid-center data-x-toggle-anim=x-grid-1></span> </span> </span></div> </a></div></div></div><div class="e154983-7 x-bar-space x-bar-space-top x-bar-space-h" style="display: none;" ></div><div class="e154983-7 x-bar x-bar-top x-bar-h x-bar-relative x-bar-is-sticky" data-x-bar={&quot;id&quot;:&quot;e154983-7&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;75px&quot;,&quot;triggerOffset&quot;:&quot;0&quot;,&quot;shrink&quot;:&quot;0&quot;} ><div class="e154983-7 x-bar-scroll x-bar-outer-spacers" data-x-scrollbar={&quot;suppressScrollY&quot;:true} ><div class="e154983-7 x-bar-content"><div class="e154983-8 x-bar-container" > <a class="e154983-9 x-image x-image-preserve-ratio" style="height: 100%; max-height: 40px;" href=https://fishduck.com > <img class=lazy alt=FishDuck src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20232%2040'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2019/04/FishDuck_Logo.png width=232 height=40> </a></div><div class="e154983-10 x-bar-container" ><div class=x-bg aria-hidden=true ></div><ul class="e154983-11 x-menu x-menu-inline  x-hide-lg x-hide-md x-hide-sm x-hide-xl x-hide-xs" ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-154990" id=menu-item-154990 > <a class="e154983-11 x-anchor x-anchor-menu-item" tabindex=0 title=Home href=https://fishduck.com ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Home</span></div></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154991" id=menu-item-154991 > <a class="e154983-11 x-anchor x-anchor-menu-item" tabindex=0 title="Analysis Library" href=https://fishduck.com/the-oregon-football-repository-by-fishduck-com/the-oregon-football-analysis-library-by-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Analysis Library</span></div></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154992" id=menu-item-154992 > <a class="e154983-11 x-anchor x-anchor-menu-item" tabindex=0 title="Football Repository" href=https://fishduck.com/2017/10/building-an-oregon-football-repository-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Football Repository</span></div></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a></li></ul> <a class="e154983-12 x-anchor x-anchor-toggle" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-12 ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <span class="x-toggle x-toggle-grid x-graphic-toggle" aria-hidden=true > <span class=x-toggle-grid-center data-x-toggle-anim=x-grid-1></span> </span> </span></div> </a></div></div></div></div><div class="e154983-13 x-bar x-bar-top x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154983-13&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;50px&quot;} ><div class="e154983-13 x-bar-content"><div class="e154983-14 x-bar-container" ><div class="e154983-15 x-text" > <marquee behavior=scroll direction=left>We are making subtle changes to the site with much more over the summer.  Watch for the new comment sign-up coming soon!</marquee></div></div></div></div></header><div class="x-container max width offset"><div class="x-main full" role=main><article id=post-179535 class="post-179535 post type-post status-publish format-standard has-post-thumbnail hentry category-recruiting tag-isaac-townsend tag-oregon-ducks tag-oregon-ducks-football tag-oregon-ducks-recruiting tag-oregon-football-redshirt-freshmen"><div class=entry-featured><div class=entry-thumb><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x88222 data-lazy-src=https://cdn3.fishduck.com/wp-content/uploads/2020/06/rosebtown-1200x800.jpeg width=1200 height=800 class="attachment-entry-fullwidth size-entry-fullwidth wp-post-image" alt srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/06/rosebtown-1200x800.jpeg?x88222 1200w, https://cdn.fishduck.com/wp-content/uploads/2020/06/rosebtown-368x245.jpeg?x88222 368w, https://cdn.fishduck.com/wp-content/uploads/2020/06/rosebtown-600x400.jpeg?x88222 600w, https://cdn1.fishduck.com/wp-content/uploads/2020/06/rosebtown-768x512.jpeg?x88222 768w, https://cdn2.fishduck.com/wp-content/uploads/2020/06/rosebtown-1536x1024.jpeg?x88222 1536w, https://cdn2.fishduck.com/wp-content/uploads/2020/06/rosebtown-2048x1365.jpeg?x88222 2048w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/rosebtown-100x67.jpeg?x88222 100w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/rosebtown-800x533.jpeg?x88222 800w" sizes="(max-width: 1200px) 100vw, 1200px" data-wp-pid=179539 nopin=nopin><noscript><img width=1200 height=800 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2020/06/rosebtown-1200x800.jpeg class="attachment-entry-fullwidth size-entry-fullwidth wp-post-image lazy" alt data-srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/06/rosebtown-1200x800.jpeg?x88222 1200w, https://cdn.fishduck.com/wp-content/uploads/2020/06/rosebtown-368x245.jpeg?x88222 368w, https://cdn.fishduck.com/wp-content/uploads/2020/06/rosebtown-600x400.jpeg?x88222 600w, https://cdn1.fishduck.com/wp-content/uploads/2020/06/rosebtown-768x512.jpeg?x88222 768w, https://cdn2.fishduck.com/wp-content/uploads/2020/06/rosebtown-1536x1024.jpeg?x88222 1536w, https://cdn2.fishduck.com/wp-content/uploads/2020/06/rosebtown-2048x1365.jpeg?x88222 2048w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/rosebtown-100x67.jpeg?x88222 100w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/rosebtown-800x533.jpeg?x88222 800w" data-sizes="(max-width: 1200px) 100vw, 1200px" data-wp-pid=179539 nopin=nopin></noscript></div></div><div class=entry-wrap><header class=entry-header><h1 class="entry-title">Is Isaac Townsend a Future OLB STAR for the Ducks?</h1><p class=p-meta><span><i class=x-icon-pencil data-x-icon-s=&#xf303;></i> Zeke Lerner-Wood</span><span><time class=entry-date datetime=2020-06-28T02:05:10-07:00><i class=x-icon-calendar data-x-icon-s=&#xf073;></i> June 28, 2020</time></span><span><a href=https://fishduck.com/category/recruiting/ title="View all posts in: &ldquo;Recruiting&rdquo;"><i class=x-icon-bookmark data-x-icon-s=&#xf02e;></i> Recruiting</a></span><span><a href=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/#disqus_thread title="Leave a comment on: &ldquo;Is Isaac Townsend a Future OLB STAR for the Ducks?&rdquo;" class=meta-comments><i class=x-icon-comments data-x-icon-s=&#xf086;></i> 34 Comments</a></span></p></header><div class="entry-content content"><div class=wpsso-pinterest-pin-it-image style="display:none !important;"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-src=https://cdn.fishduck.com/wp-content/uploads/2020/06/rosebtown-800x533.jpeg width=0 height=0 class="skip-lazy lazy" style=width:0;height:0; alt data-pin-description="In 2018, the NCAA proposed that redshirted players could participate in up to four games in a season without burning up a year of collegiate athletic..."></div><div class="wpsso-rrssb wpsso-rrssb-content" id=wpsso-rrssb-content-post-179535><div class="wpsso-rrssb-limit wpsso-rrssb-content-limit" style=max-width:460px;><ul class="rrssb-buttons en_US clearfix"><li class=rrssb-facebook> <a href="https://www.facebook.com/sharer/sharer.php?u=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/" class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg preserveAspectRatio=xMidYMid width=29 height=29 viewBox="0 0 29 29"> <path d="M26.4 0H2.6C1.714 0 0 1.715 0 2.6v23.8c0 .884 1.715 2.6 2.6 2.6h12.393V17.988h-3.996v-3.98h3.997v-3.062c0-3.746 2.835-5.97 6.177-5.97 1.6 0 2.444.173 2.845.226v3.792H21.18c-1.817 0-2.156.9-2.156 2.168v2.847h5.045l-.66 3.978h-4.386V29H26.4c.884 0 2.6-1.716 2.6-2.6V2.6c0-.885-1.716-2.6-2.6-2.6z" class=cls-2 fill-rule=evenodd /> </svg> </span> <span class=rrssb-text>facebook</span> </a></li><li class=rrssb-twitter> <a href="https://twitter.com/intent/+/tweet?original_referer=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/&url=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/&text=Is%20Isaac%20Townsend%20a%20Future%20OLB%20STAR%20for%20the%20Ducks%3F%20%23IsaacTownsend&via=fishduckdotcom" class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M24.253 8.756C24.69 17.08 18.297 24.182 9.97 24.62c-3.122.162-6.22-.646-8.86-2.32 2.702.18 5.375-.648 7.507-2.32-2.072-.248-3.818-1.662-4.49-3.64.802.13 1.62.077 2.4-.154-2.482-.466-4.312-2.586-4.412-5.11.688.276 1.426.408 2.168.387-2.135-1.65-2.73-4.62-1.394-6.965C5.574 7.816 9.54 9.84 13.802 10.07c-.842-2.738.694-5.64 3.434-6.48 2.018-.624 4.212.043 5.546 1.682 1.186-.213 2.318-.662 3.33-1.317-.386 1.256-1.248 2.312-2.4 2.942 1.048-.106 2.07-.394 3.02-.85-.458 1.182-1.343 2.15-2.48 2.71z"/> </svg> </span> <span class=rrssb-text>twitter</span> </a></li><li class=rrssb-reddit> <a href="http://www.reddit.com/submit?url=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/&title=Is%20Isaac%20Townsend%20a%20Future%20OLB%20STAR%20for%20the%20Ducks%3F&text=In%202018%2C%20the%20NCAA%20proposed%20that%20redshirted%20players%20could%20participate%20in%20up%20to%20four%20games%20in%20a%20season%20without%20burning%20up%20a%20year%20of%20collegiate%20athletic..."> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M11.794 15.316c0-1.03-.835-1.895-1.866-1.895-1.03 0-1.893.866-1.893 1.896s.863 1.9 1.9 1.9c1.023-.016 1.865-.916 1.865-1.9zM18.1 13.422c-1.03 0-1.895.864-1.895 1.895 0 1 .9 1.9 1.9 1.865 1.03 0 1.87-.836 1.87-1.865-.006-1.017-.875-1.917-1.875-1.895zM17.527 19.79c-.678.68-1.826 1.007-3.514 1.007h-.03c-1.686 0-2.834-.328-3.51-1.005-.264-.265-.693-.265-.958 0-.264.265-.264.7 0 1 .943.9 2.4 1.4 4.5 1.402.005 0 0 0 0 0 .005 0 0 0 0 0 2.066 0 3.527-.46 4.47-1.402.265-.264.265-.693.002-.958-.267-.334-.688-.334-.988-.043z"/> <path d="M27.707 13.267c0-1.785-1.453-3.237-3.236-3.237-.792 0-1.517.287-2.08.76-2.04-1.294-4.647-2.068-7.44-2.218l1.484-4.69 4.062.955c.07 1.4 1.3 2.6 2.7 2.555 1.488 0 2.695-1.208 2.695-2.695C25.88 3.2 24.7 2 23.2 2c-1.06 0-1.98.616-2.42 1.508l-4.633-1.09c-.344-.082-.693.117-.803.454l-1.793 5.7C10.55 8.6 7.7 9.4 5.6 10.75c-.594-.45-1.3-.75-2.1-.72-1.785 0-3.237 1.45-3.237 3.2 0 1.1.6 2.1 1.4 2.69-.04.27-.06.55-.06.83 0 2.3 1.3 4.4 3.7 5.9 2.298 1.5 5.3 2.3 8.6 2.325 3.227 0 6.27-.825 8.57-2.325 2.387-1.56 3.7-3.66 3.7-5.917 0-.26-.016-.514-.05-.768.965-.465 1.577-1.565 1.577-2.698zm-4.52-9.912c.74 0 1.3.6 1.3 1.3 0 .738-.6 1.34-1.34 1.34s-1.343-.602-1.343-1.34c.04-.655.596-1.255 1.396-1.3zM1.646 13.3c0-1.038.845-1.882 1.883-1.882.31 0 .6.1.9.21-1.05.867-1.813 1.86-2.26 2.9-.338-.328-.57-.728-.57-1.26zm20.126 8.27c-2.082 1.357-4.863 2.105-7.83 2.105-2.968 0-5.748-.748-7.83-2.105-1.99-1.3-3.087-3-3.087-4.782 0-1.784 1.097-3.484 3.088-4.784 2.08-1.358 4.86-2.106 7.828-2.106 2.967 0 5.7.7 7.8 2.106 1.99 1.3 3.1 3 3.1 4.784C24.86 18.6 23.8 20.3 21.8 21.57zm4.014-6.97c-.432-1.084-1.19-2.095-2.244-2.977.273-.156.59-.245.928-.245 1.036 0 1.9.8 1.9 1.9-.016.522-.27 1.022-.57 1.327z"/> </svg> </span> <span class=rrssb-text>reddit</span> </a></li><li class=rrssb-linkedin> <a href="http://www.linkedin.com/shareArticle?mini=true&url=https://fishduck.com/2020/06/is-isaac-townsend-a-future-olb-star-for-the-ducks/&title=Is%20Isaac%20Townsend%20a%20Future%20OLB%20STAR%20for%20the%20Ducks%3F&summary=In%202018%2C%20the%20NCAA%20proposed%20that%20redshirted%20players%20could%20participate%20in%20up%20to%20four%20games%20in%20a%20season%20without%20burning%20up%20a%20year%20of%20collegiate%20athletic..." class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M25.424 15.887v8.447h-4.896v-7.882c0-1.98-.71-3.33-2.48-3.33-1.354 0-2.158.91-2.514 1.802-.13.315-.162.753-.162 1.194v8.216h-4.9s.067-13.35 0-14.73h4.9v2.087c-.01.017-.023.033-.033.05h.032v-.05c.65-1.002 1.812-2.435 4.414-2.435 3.222 0 5.638 2.106 5.638 6.632zM5.348 2.5c-1.676 0-2.772 1.093-2.772 2.54 0 1.42 1.066 2.538 2.717 2.546h.032c1.71 0 2.77-1.132 2.77-2.546C8.056 3.593 7.02 2.5 5.344 2.5h.005zm-2.48 21.834h4.896V9.604H2.867v14.73z"/> </svg> </span> <span class=rrssb-text>linkedin</span> </a></li></ul></div></div><div class=pf-content><p><span style="font-weight: 400;">In 2018, the NCAA proposed that redshirted players could participate in up to four games in a season without burning up a year of collegiate athletic eligibility. This was a fantastic rule change in the eyes of many coaches, as it allowed for more flexibility on rosters, as well as for players, who could </span><span style="font-weight: 400;">test</span><span style="font-weight: 400;"> playing at another level of their respective sport for the first time without wasting an entire season of eligibility.&#160;</span></p><p><span style="font-weight: 400;">As sports get only more and more competitive, naturally the fight for playing time does as well. When a player commits to joining a nationally recognized football program, he is literally taking the sport to another level, and time to develop in order to be able to compete is often necessary. Often these players already have very solid foundations, and the main issue that separates them from the bench and the field has to do with size and weight. Newly graduated Duck and freshly signed New Orleans Saint </span><b>Calvin Throckmorton</b><span style="font-weight: 400;"> didn&#8217;t see playing time until his second year with the program, but he eventually became an essential figure in the offensive line as an upperclassman.</span></p><p><span style="font-weight: 400;">Players like this make me excited. </span><b>Isaac Townsend </b><span style="font-weight: 400;">is exactly that kind of player. Townsend is a 6&#8217;5, 265 pound outside linebacker from Arvada, Colorado. The 3-star big man was the No. 2 overall ranked player in Colorado upon recruitment, and he finished up his senior high school season at Ralston Valley HS with 51 tackles, 11 for loss, and three sacks. He played basketball in high schools well,&#160; and chose Oregon over other notable programs such as Notre Dame, Nebraska, and Washington State.</span></p><div id=attachment_179547 class="wp-caption aligncenter" style="width: 1200px"><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x88222 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3.png class=wp-image-179547 alt width=1200 height=932 data-wp-pid=179547 srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3.png?x88222 600w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3-315x245.png?x88222 315w, https://cdn.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3-515x400.png?x88222 515w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3-100x78.png?x88222 100w" sizes="(max-width: 1200px) 100vw, 1200px"><noscript><img class="wp-image-179547 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20932'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3.png alt width=1200 height=932 data-wp-pid=179547 data-srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3.png?x88222 600w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3-315x245.png?x88222 315w, https://cdn.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3-515x400.png?x88222 515w, https://cdn3.fishduck.com/wp-content/uploads/2020/06/isaac-townsend-ce14797cdaf605b3-100x78.png?x88222 100w" data-sizes="(max-width: 1200px) 100vw, 1200px"></noscript><p class=attr-credit-text>From Twitter</p><p class=wp-caption-text>Townsend upon commitment.</p></div><p><span style="font-weight: 400;">Townsend didn&#8217;t see any playing time last fall. This can be especially daunting as a freshman, especially when the rules allow you the opportunity to play without affecting eligibility. A major contributing factor to this is that Townsend only weighed 235 pounds upon signing, which is a bit undersized in comparison to the Duck&#8217;s 2019 offensive line which averaged a weight of around 315 pounds. He was simply not at the same level physically as his competition. Since then, he has put on almost 35 pounds, likely the result of hard work, quality coaching, and college meal plans. Townsend was on the list of the top five largest weight gains on the Duck&#8217;s roster in 2019.</span></p><p><span style="font-weight: 400;">In an article by James Crepea published on </span><a href=https://www.oregonlive.com/ducks/2020/03/after-redshirting-in-2019-bulked-up-treven-maae-isaac-townsend-competing-for-time-at-stud-end-for-oregon-ducks.html><b>Oregon Live</b></a><span style="font-weight: 400;">, Townsend commented on the growth he&#8217;s achieved:</span></p><p><i><span style="font-weight: 400;">&#8220;It was kind of tough to not play but after helping my offensive teammates, giving them looks on the field, I think I learned a lot about myself as a person and developed as a man so I was able to take it into this year. I was trying to get power and strength behind me as long as it was good weight so I could still move. I think some of that is I&#8217;m getting older so it&#8217;s easier to put on more weight but that was also what I was trying to do and I&#8217;m happy it&#8217;s happening.</span></i></p><div id=attachment_179537 class="wp-caption aligncenter" style="width: 1200px"><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x88222 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2020/06/townuponrecruit.jpg class=wp-image-179537 alt width=1200 height=619 data-wp-pid=179537 srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/06/townuponrecruit.jpg?x88222 620w, https://cdn1.fishduck.com/wp-content/uploads/2020/06/townuponrecruit-475x245.jpg?x88222 475w, https://cdn2.fishduck.com/wp-content/uploads/2020/06/townuponrecruit-100x52.jpg?x88222 100w" sizes="(max-width: 1200px) 100vw, 1200px"><noscript><img class="wp-image-179537 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20619'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2020/06/townuponrecruit.jpg alt width=1200 height=619 data-wp-pid=179537 data-srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/06/townuponrecruit.jpg?x88222 620w, https://cdn1.fishduck.com/wp-content/uploads/2020/06/townuponrecruit-475x245.jpg?x88222 475w, https://cdn2.fishduck.com/wp-content/uploads/2020/06/townuponrecruit-100x52.jpg?x88222 100w" data-sizes="(max-width: 1200px) 100vw, 1200px"></noscript><p class=attr-credit-text>Twitter</p><p class=wp-caption-text>Townsend poses for a photo shortly after visiting Eugene last year.</p></div><p><span style="font-weight: 400;">Townsend has all the makings of a fantastic linesman. He&#8217;s a great height for the position, and he&#8217;s gained a lot of weight quickly. He has the length and frame to be a real asset on both offensive and defensive lines, and with a year on the sideline it&#8217;s safe to say that tactically he&#8217;s been paying attention. Townsend is very quick off of his feet. This makes him a fantastic rusher who can often get a quick first step ahead of his competitors. This is very valuable as it will allow him to penetrate the backfield and lay waste to opponents in his way. You can see the voraciousness in Townsend&#8217;s playstyle.&#160;</span><i></i></p><p><span style="font-weight: 400;">Overall, Townsend is a very promising player who has all the tools that he needs to be great. With that first year under his belt, he is not only mentally equipped, but is more physically prepared than ever. I think that we could see Townsend playing on the third team next season, but I still believe that he has a bit further to develop physically. Hopefully, this next season really allows for him to grow into the impact player that I am confident Townsend can become.</span></p><p><strong>Zeke Lerner-Wood</strong><br> Alameda, California<br> <em>Top photo by&#160;</em><strong>Tom Corno</strong></p><div class="printfriendly pf-alignright"><a href=# rel=nofollow onclick="window.print(); return false;" title="Printer Friendly, PDF & Email"><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x88222 data-lazy-src=https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" alt="Print Friendly, PDF &amp; Email"><noscript><img class=lazy style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png alt="Print Friendly, PDF & Email"></noscript></a></div></div><div class=relpost-thumb-wrapper><div class=relpost-thumb-container><h3>Related Articles:</h3><div style="clear: both"></div><div style="clear: both"></div><div class=relpost-block-container><a class=relpost-block-single href=https://fishduck.com/2020/06/rocky-top-redshirt-lance-wilhoite-is-in-the-ducks-future/ ><div style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Rocky Top Redshirt Lance Wilhoite is Ducks' Next BREAK-OUT Receiver?"  style="background: transparent url(https://cdn1.fishduck.com/wp-content/uploads/2020/06/LanceWilhoite-1-150x150.png?x88222) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Rocky Top Redshirt Lance Wilhoite is Ducks' Next BREAK-OUT Receiver?</div></div></a><a class=relpost-block-single href=https://fishduck.com/2020/06/recruiting-update-the-curious-case-of-no-1-recruit-korey-foreman/ ><div style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Recruiting Update: The Curious Case of No. 1 Recruit Korey Foreman"  style="background: transparent url(https://cdn3.fishduck.com/wp-content/uploads/2020/01/habibi-e1579319353533-150x150.jpg?x88222) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Recruiting Update: The Curious Case of No. 1 Recruit Korey Foreman</div></div></a><a class=relpost-block-single href=https://fishduck.com/2020/06/will-jr-waters-stack-up-to-the-rest/ ><div style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Is JR Waters the Ducks Next Break-Out Receiver?"  style="background: transparent url(https://cdn3.fishduck.com/wp-content/uploads/2020/06/0028131-gysg-1280x720-1-150x150.jpg?x88222) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Is JR Waters the Ducks Next Break-Out Receiver?</div></div></a><a class=relpost-block-single href=https://fishduck.com/2020/06/the-big-ugly-ducklings-jonah-tauanuu-is-here-to-compete/ ><div style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="The Big Ugly Ducklings: Jonah Tauanu'u is Here to Compete"  style="background: transparent url(https://cdn1.fishduck.com/wp-content/uploads/2020/06/JonahTuauanuu-150x150.png?x88222) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">The Big Ugly Ducklings: Jonah Tauanu'u is Here to Compete</div></div></a><a class=relpost-block-single href=https://fishduck.com/2020/05/trikweze-bridges-the-bravura-ballhawk/ ><div style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Trikweze Bridges: The Bravura Ballhawk"  style="background: transparent url(https://cdn1.fishduck.com/wp-content/uploads/2020/05/bridges2-150x150.png?x88222) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Trikweze Bridges: The Bravura Ballhawk</div></div></a><a class=relpost-block-single href=https://fishduck.com/2020/05/new-flock-of-ducks-oregon-women-add-sharpshooting-transfer/ ><div style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="New Flock of Ducks: Oregon Women Add Sharpshooting Transfer"  style="background: transparent url(https://cdn3.fishduck.com/wp-content/uploads/2020/05/Pit-Crew-150x150.jpg?x88222) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">New Flock of Ducks: Oregon Women Add Sharpshooting Transfer</div></div></a></div><div style="clear: both"></div></div></div><div class=saboxplugin-wrap itemtype=http://schema.org/Person itemscope itemprop=author><div class=saboxplugin-gravatar><a href=https://fishduck.com/author/zeke-lerner-wood/ ><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x88222 data-lazy-src=https://cdn3.fishduck.com/wp-content/uploads/2020/02/Zeke-Lerner-Wood.jpg alt itemprop=image><noscript><img class=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2020/02/Zeke-Lerner-Wood.jpg alt itemprop=image></noscript></a></div><div class=saboxplugin-authorname><a href=https://fishduck.com/author/zeke-lerner-wood/ class="vcard author" rel=author itemprop=url><span class=fn itemprop=name>Zeke Lerner-Wood</span></a></div><div class=saboxplugin-desc><div itemprop=description><p>Zeke Lerner-Wood is a freshman at the University of Oregon from Alameda, California. Growing up in the Bay, Zeke follows the A&#8217;s, Raiders, and Warriors and since starting classes at the University, Zeke has been introduced to the world of NCAA football and has become an avid fan.</p></div></div><div class=clearfix></div></div><div class=awac-wrapper><div class="awac widget text-87"><h4 class="widget-title">Mr. FishDuck has Your BACK!</h4><div class=textwidget><p><em>Good gosh!</em>  This site has been barraged by some nasty posts/comments recently, and the good news is that few of you saw <strong><em>any</em></strong> of them.  I&#8217;ve had about a dozen come in late at night as insults to the program and Oregon fans, while others were political comments, that, while in a few cases were benign, could have started an a firestorm.</p><p><em>(And we let people state their political views on all the <strong>other</strong> sites.)</em></p><p>We have had a number of <strong><em>&#8220;Drive-By Trolls&#8221;</em></strong> that actually take the trouble to sign up&#8211;just to fling<em> silly epithets</em> that I delete in a heartbeat.  Know that I love this community and am committed to keeping it safe for everyone.</p><p>The majority of <strong><a href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ >our rules</a></strong> can be summarized to this: 1) <strong>be polite and respectful</strong>, 2) <strong>keep it clean for grandchildren reading</strong>, and 3) <strong>no reference to politics</strong>.</p><p><em>Easy-Peasy!</em></p></div></div></div></div></div><footer class="entry-footer cf"> <a href=https://fishduck.com/tag/isaac-townsend/ rel=tag>Isaac Townsend</a><a href=https://fishduck.com/tag/oregon-ducks/ rel=tag>Oregon Ducks</a><a href=https://fishduck.com/tag/oregon-ducks-football/ rel=tag>Oregon Ducks Football</a><a href=https://fishduck.com/tag/oregon-ducks-recruiting/ rel=tag>Oregon Ducks Recruiting</a><a href=https://fishduck.com/tag/oregon-football-redshirt-freshmen/ rel=tag>Oregon Football Redshirt Freshmen</a></footer></article><div id=disqus_thread><div id=dcl_btn_container> <button id=dcl_comment_btn class=disqus-button> Load Comments	</button></div></div></div></div><footer class=x-colophon role=contentinfo ><div class="e154993-1 x-bar x-bar-footer x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154993-1&quot;,&quot;region&quot;:&quot;footer&quot;,&quot;height&quot;:&quot;auto&quot;} ><div class="e154993-1 x-bar-content"><div class="e154993-2 x-bar-container" > <a class="e154993-3 x-image" href=https://fishduck.com > <img class=lazy alt="Fish Duck" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20232%2040'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2019/04/FishDuck_Logo.png width=232 height=40> </a></div><div class="e154993-4 x-bar-container" > <a class="e154993-5 x-anchor x-anchor-button" tabindex=0 href=https://www.facebook.com/FishDuckOnline/ ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf09a; ></i></span></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-6 x-anchor x-anchor-button" tabindex=0 href=https://twitter.com/fishduckdotcom ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf099; ></i></span></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-7 x-anchor x-anchor-button" tabindex=0 href=https://www.youtube.com/user/FishDuck83 ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf167; ></i></span></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a></div><div class="e154993-8 x-bar-container" ><ul class="e154993-9 x-menu x-menu-inline" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154994" id=menu-item-154994 > <a class="e154993-9 x-anchor x-anchor-menu-item" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154995" id=menu-item-154995 > <a class="e154993-9 x-anchor x-anchor-menu-item" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154996" id=menu-item-154996 > <a class="e154993-9 x-anchor x-anchor-menu-item" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154997" id=menu-item-154997 > <a class="e154993-9 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li></ul></div></div></div><div class="e154993-10 x-bar x-bar-footer x-bar-h x-bar-relative  x-hide-xl x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154993-10&quot;,&quot;region&quot;:&quot;footer&quot;,&quot;height&quot;:&quot;auto&quot;} ><div class="e154993-10 x-bar-content"><div class="e154993-11 x-bar-container" > <span class="e154993-12 x-image" > <img class=lazy alt=Image src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20232%2040'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2019/04/FishDuck_Logo.png width=232 height=40> </span></div><div class="e154993-13 x-bar-container" > <a class="e154993-14 x-anchor x-anchor-button" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf09a; ></i></span></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-15 x-anchor x-anchor-button" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf099; ></i></span></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-16 x-anchor x-anchor-button" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf167; ></i></span></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a></div><div class="e154993-17 x-bar-container" ><ul class="e154993-18 x-menu x-menu-inline" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154994" > <a class="e154993-18 x-anchor x-anchor-menu-item" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154995" > <a class="e154993-18 x-anchor x-anchor-menu-item" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154996" > <a class="e154993-18 x-anchor x-anchor-menu-item" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154997" > <a class="e154993-18 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle x-anchor-particle-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a></li></ul></div></div></div></footer><div id=e154983-6-off-canvas class="e154983-6 x-off-canvas x-off-canvas-right  x-hide-lg x-hide-md x-hide-sm x-hide-xl" role=dialog tabindex=-1 data-x-toggleable=e154983-6 aria-hidden=true aria-label="Off Canvas" ><span class=x-off-canvas-bg></span><button class="x-off-canvas-close x-off-canvas-close-right" data-x-toggle-close=1 aria-label="Close Off Canvas Content" > <span>&times;</span> </button><div class="x-off-canvas-content x-off-canvas-content-right" data-x-scrollbar={&quot;suppressScrollX&quot;:true} role=document aria-label="Off Canvas Content" ><ul class="e154983-6 x-menu x-menu-collapsed" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154985" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154986" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154987" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154988" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=Contact href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li></ul></div></div><div id=e154983-12-off-canvas class="e154983-12 x-off-canvas x-off-canvas-right" role=dialog tabindex=-1 data-x-toggleable=e154983-12 aria-hidden=true aria-label="Off Canvas" ><span class=x-off-canvas-bg></span><button class="x-off-canvas-close x-off-canvas-close-right" data-x-toggle-close=1 aria-label="Close Off Canvas Content" > <span>&times;</span> </button><div class="x-off-canvas-content x-off-canvas-content-right" data-x-scrollbar={&quot;suppressScrollX&quot;:true} role=document aria-label="Off Canvas Content" ><ul class="e154983-12 x-menu x-menu-collapsed" ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-178454" id=menu-item-178454 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Home</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178451" id=menu-item-178451 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178452" id=menu-item-178452 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178453" id=menu-item-178453 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178450" id=menu-item-178450 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178455" id=menu-item-178455 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/the-oregon-football-repository-by-fishduck-com/the-oregon-football-analysis-library-by-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Analysis Library</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178456" id=menu-item-178456 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/2017/10/building-an-oregon-football-repository-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Football Repository</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178457" id=menu-item-178457 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/join-fishduck-com-main-page/student-internship-opportunities-at-fishduck-com/sports-reporter-internship/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Top Photo Credit</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a></li></ul></div></div></div> <a class="x-scroll-top right fade" title="Back to Top"> <i class=x-icon-angle-up data-x-icon-s=&#xf106;></i> </a> <script>jQuery(document).ready(function($){var $window=$(window);var body=$('body');var bodyOffsetBottom=$window.scrollBottom();var bodyHeightAdjustment=body.height()-bodyOffsetBottom;var bodyHeightAdjusted=body.height()-bodyHeightAdjustment;var $scrollTopAnchor=$('.x-scroll-top');function sizingUpdate(){var bodyOffsetTop=$window.scrollTop();if(bodyOffsetTop>(bodyHeightAdjusted*0.75)){$scrollTopAnchor.addClass('in');}else{$scrollTopAnchor.removeClass('in');}}$window.on('scroll',sizingUpdate).resize(sizingUpdate);sizingUpdate();$scrollTopAnchor.on('click',function(){$('html, body').animate({scrollTop:0},850,'xEaseInOutExpo');return false;});});</script> </div>  <script>var pfHeaderImgUrl='';var pfHeaderTagline='';var pfdisableClickToDel='0';var pfImagesSize='full-size';var pfImageDisplayStyle='right';var pfEncodeImages='0';var pfDisableEmail='0';var pfDisablePDF='0';var pfDisablePrint='0';var pfCustomCSS='';var pfPlatform='Wordpress';</script> <script async src=https://cdn.printfriendly.com/printfriendly.js></script> <script>var countVars={"disqusShortname":"fishduck"};var embedVars={"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"179535 https:\/\/fishduck.com\/?p=179535","disqusShortname":"fishduck","disqusTitle":"Is Isaac Townsend a Future OLB STAR for the Ducks?","disqusUrl":"https:\/\/fishduck.com\/2020\/06\/is-isaac-townsend-a-future-olb-star-for-the-ducks\/","postId":"179535"};var dclCustomVars={"dcl_progress_text":"Loading..."};</script> <script src='https://cdn1.fishduck.com/wp-content/plugins/disqus-conditional-load/assets/js/public/embed-click.min.js?x88222'></script> <script src=https://cdn1.fishduck.com/wp-content/themes/pro/cornerstone/assets/dist/js/site/cs.fa34ec9.js?x88222></script> <script src='https://cdn1.fishduck.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?x88222'></script> <script src='https://cdn1.fishduck.com/wp-content/plugins/lazy-load/js/lazy-load.js?x88222'></script> <script src='https://cdn1.fishduck.com/wp-content/plugins/wpsso-rrssb/js/ext/rrssb.min.js?x88222'></script> <script src='https://cdn1.fishduck.com/wp-content/themes/pro/framework/dist/js/site/x.js?x88222'></script> <script src='https://cdn1.fishduck.com/wp-includes/js/wp-embed.min.js?x88222'></script> <script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script async src=https://cdn1.fishduck.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js?x88222></script></body></html>