<!DOCTYPE html><html class=no-js lang=en-US prefix="og: https://ogp.me/ns# fb: https://ogp.me/ns/fb# article: https://ogp.me/ns/article#"><head><style>img.lazy{min-height:1px}</style><link rel=preload href=https://cdn1.fishduck.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js?x46742 as=script><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel=pingback href=https://fishduck.com/xmlrpc.php><title>Oregon&#8217;s BIGGEST Unknown Player for 2021? | FishDuck</title><meta name='robots' content='max-image-preview:large'><meta name="description" content="The Spring Game was certainly a coming-out party for quite a number of freshmen, as we were all impressed with the new players in Robby Ashford, Ty Thompson&#8230;"><link rel=canonical href=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/ ><link rel=alternate type=application/rss+xml title="FishDuck &raquo; Feed" href=https://fishduck.com/feed/ ><link rel=alternate type=application/rss+xml title="FishDuck &raquo; Comments Feed" href=https://fishduck.com/comments/feed/ ><link rel=alternate type=application/rss+xml title="FishDuck &raquo; Oregon&#8217;s BIGGEST Unknown Player for 2021? Comments Feed" href=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/feed/ ><link rel=stylesheet href=https://cdn.fishduck.com/wp-content/cache/minify/aeaa7.css?x46742 media=all><style id=wpdiscuz-frontend-css-inline-css>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</style><link rel=stylesheet href=https://cdn.fishduck.com/wp-content/cache/minify/d1ff3.css?x46742 media=all> <script src='https://cdn1.fishduck.com/wp-includes/js/jquery/jquery.min.js?x46742' id=jquery-core-js></script> <script src='https://cdn1.fishduck.com/wp-includes/js/jquery/jquery-migrate.min.js?x46742' id=jquery-migrate-js></script> <link rel=https://api.w.org/ href=https://fishduck.com/wp-json/ ><link rel=alternate type=application/json href=https://fishduck.com/wp-json/wp/v2/posts/188400> <script>_atrk_opts={atrk_acct:"O+dIk1ao6C52O7",domain:"fishduck.com",dynamic:true};(function(){var as=document.createElement('script');as.type='text/javascript';as.async=true;as.src="https://certify-js.alexametrics.com/atrk.js";var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as,s);})();</script> <noscript><img class=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src="https://certify.alexametrics.com/atrk.gif?account=O+dIk1ao6C52O7" style=display:none height=1 width=1 alt></noscript><meta property="fb:pages" content="266952793316048">  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-24966687-1"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-24966687-1');</script> <style>@media screen{.printfriendly{position:relative;z-index:1000;margin:12px 12px 12px 12px}.printfriendly a, .printfriendly a:link, .printfriendly a:visited, .printfriendly a:hover, .printfriendly a:active{font-weight:600;cursor:pointer;text-decoration:none;border:none;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;outline:none;font-size:14px !important;color:#6D9F00 !important}.printfriendly.pf-alignleft{float:left}.printfriendly.pf-alignright{float:right}.printfriendly.pf-aligncenter{display:flex;align-items:center;justify-content:center}}@media print{.printfriendly{display:none}}.pf-button.pf-button-excerpt{display:none}</style><style>#related_posts_thumbnails li{border-right:1px solid #ddd;background-color:#fff}#related_posts_thumbnails li:hover{background-color:#eee}.relpost_content{font-size:12px;color:#333}.relpost-block-single{background-color:#fff;border-right:1px solid  #ddd;border-left:1px solid  #ddd;margin-right:-1px}.relpost-block-single:hover{background-color:#eee}</style><meta name="wpsso-begin" content="wpsso meta tags and schema markup begin"><meta name="generator" content="WPSSO Core 8.35.0/L*"><meta name="generator" content="WPSSO RRSSB 6.0.0/S"><meta name="generator" content="WPSSO UM 4.4.1/S"><link rel=shortlink href="https://fishduck.com/?p=188400"><meta property="fb:app_id" content="146912038807686"><meta property="og:type" content="article"><meta property="og:url" content="https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/"><meta property="og:locale" content="en_US"><meta property="og:site_name" content="FishDuck"><meta property="og:title" content="Oregon&#039;s BIGGEST Unknown Player for 2021? | FishDuck"><meta property="og:description" content="The Spring Game was certainly a coming-out party for quite a number of freshmen, as we were all impressed with the new players in Robby Ashford, Ty Thompson..."><meta property="og:updated_time" content="2021-07-07T01:00:03+00:00"><meta property="og:image" content="https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-762x400.jpg?x46742"><meta property="og:image:width" content="762"><meta property="og:image:height" content="400"><meta property="article:publisher" content="https://www.facebook.com/FishDuckOnline"><meta property="article:published_time" content="2021-07-11T09:05:58+00:00"><meta property="article:modified_time" content="2021-07-07T01:00:03+00:00"><meta property="article:tag" content="Logan Sagapolu"><meta property="article:tag" content="Oregon Offensive Line"><meta name="twitter:domain" content="fishduck.com"><meta name="twitter:site" content="@fishduckdotcom"><meta name="twitter:title" content="Oregon&#039;s BIGGEST Unknown Player for 2021? | FishDuck"><meta name="twitter:description" content="The Spring Game was certainly a coming-out party for quite a number of freshmen, as we were all impressed with the new players in Robby Ashford, Ty Thompson..."><meta name="twitter:card" content="summary_large_image"><meta name="twitter:image" content="https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-300x300-cropped.jpg?x46742"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Charles Fischer, Mr. FishDuck"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="5 minutes"><link itemprop=url href=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/ ><meta itemprop="name" content="Oregon&#039;s BIGGEST Unknown Player for 2021? | FishDuck"><meta itemprop="description" content="The Spring Game was certainly a coming-out party for quite a number of freshmen, as we were all impressed with the new players in Robby Ashford, Ty Thompson..."><link itemprop=thumbnailurl href=https://cdn.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-600x315-cropped.jpg?x46742><meta name="thumbnail" content="https://cdn.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-600x315-cropped.jpg?x46742"><meta name="wpsso-end" content="wpsso meta tags and schema markup end"><meta name="wpsso-cached" content="2021-07-11T21:00:33+00:00"><meta name="wpsso-added" content="2021-07-11T21:33:09+00:00 in 0.000775 secs for https://fishduck.com"><style>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</style><link rel=icon href=https://cdn.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-32x32.png sizes=32x32><link rel=icon href=https://cdn2.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-192x192.png sizes=192x192><link rel=apple-touch-icon href=https://cdn2.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-180x180.png?x46742><meta name="msapplication-TileImage" content="https://cdn2.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-270x270.png?x46742"><style id=wp-custom-css>#spMainContainer #spAck{display:none}#wppb-submit,#recover_password,#edit_profile,#register{color:#000}</style><style id=x-generated-css>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</style><link rel=stylesheet href="//fonts.googleapis.com/css?family=Lato:400,400i,700,700i&#038;subset=latin,latin-ext&#038;display=auto" type=text/css media=all data-x-google-fonts></head><body class="post-template-default single single-post postid-188400 single-format-standard x-integrity x-integrity-light x-full-width-layout-active x-full-width-active pro-v4_2_3"><div id=x-root class=x-root ><div id=x-site class="x-site site" ><header class=x-masthead role=banner ><div class="e154983-1 x-bar x-bar-top x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xl x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154983-1&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;4em&quot;} ><div class="e154983-1 x-bar-content"><div class="e154983-2 x-bar-container" ><ul class="e154983-3 x-menu x-menu-inline  x-hide-xs x-menu-first-level" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154985" id=menu-item-154985 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154986" id=menu-item-154986 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154987" id=menu-item-154987 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154988" id=menu-item-154988 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Contact href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul><div class="e154983-4 x-mod-container" > <a class="e154983-4 x-anchor x-anchor-toggle has-graphic has-particle" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-4 aria-controls=e154983-4-dropdown aria-expanded=false aria-haspopup=true aria-label="Toggle Dropdown Content" ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-s=&#xf002; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-b_c" aria-hidden=true > <span></span> </span> </a><div id=e154983-4-dropdown class="e154983-4 x-dropdown" data-x-stem data-x-stem-top data-x-toggleable=e154983-4 aria-hidden=true ><form class="e154983-4 x-search" data-x-search={&quot;search&quot;:true} action=https://fishduck.com/ method=get ><label class=visually-hidden for=s-e154983-4 >Search</label><input id=s-e154983-4 class=x-search-input type=search name=s value tabindex=0 placeholder=Search> <button class="x-search-btn x-search-btn-submit" type=button data-x-search-submit tabindex=0 ><span class=visually-hidden>Submit</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><circle fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 cx=10 cy=10 r=9 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=22 y1=22 x2=16.4 y2=16.4 stroke-linejoin=miter /></svg></button> <button class="x-search-btn x-search-btn-clear" type=button data-x-search-clear tabindex=0 ><span class=visually-hidden>Clear</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=5 x2=5 y2=19 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=19 x2=5 y2=5 stroke-linejoin=miter /></svg></button></form></div></div></div><div class="e154983-5 x-bar-container" > <a class="e154983-6 x-anchor x-anchor-toggle  x-hide-lg x-hide-md x-hide-sm x-hide-xl has-graphic" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-6 data-x-toggle-overlay=1 aria-controls=e154983-6-off-canvas aria-expanded=false aria-haspopup=true aria-label="Toggle Off Canvas Content" ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <span class="x-toggle x-toggle-grid x-graphic-child x-graphic-toggle" aria-hidden=true > <span class=x-toggle-grid-center data-x-toggle-anim=x-grid-1></span> </span> </span></div> </a></div></div></div><div class="e154983-7 x-bar-space x-bar-space-top x-bar-space-h" style="display: none;" ></div><div class="e154983-7 x-bar x-bar-top x-bar-h x-bar-relative x-bar-is-sticky" data-x-bar={&quot;id&quot;:&quot;e154983-7&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;75px&quot;,&quot;triggerOffset&quot;:&quot;0&quot;,&quot;shrink&quot;:&quot;0&quot;,&quot;scroll&quot;:true} ><div class="e154983-7 x-bar-scroll-outer" ><div class="e154983-7 x-bar-scroll-inner x-bar-outer-spacers" ><div class="e154983-7 x-bar-content"><div class="e154983-8 x-bar-container" > <a class="e154983-9 x-image x-image-preserve-ratio" style="height: 100%; max-height: 59.5px;" href=https://fishduck.com > <img class=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20225%2059'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2020/12/FishDuck-Community-Logo.png width=225 height=59.5 alt=FishDuck loading=lazy> </a></div><div class="e154983-10 x-bar-container" ><ul class="e154983-11 x-menu x-menu-inline  x-hide-lg x-hide-md x-hide-sm x-hide-xl x-hide-xs x-menu-first-level" ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-154990" id=menu-item-154990 > <a class="e154983-11 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Home href=https://fishduck.com ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Home</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154991" id=menu-item-154991 > <a class="e154983-11 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Analysis Library" href=https://fishduck.com/the-oregon-football-repository-by-fishduck-com/the-oregon-football-analysis-library-by-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Analysis Library</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154992" id=menu-item-154992 > <a class="e154983-11 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Football Repository" href=https://fishduck.com/2017/10/building-an-oregon-football-repository-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Football Repository</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul> <a class="e154983-12 x-anchor x-anchor-toggle has-graphic" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-12 data-x-toggle-overlay=1 aria-controls=e154983-12-off-canvas aria-expanded=false aria-haspopup=true aria-label="Toggle Off Canvas Content" ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <span class="x-toggle x-toggle-grid x-graphic-child x-graphic-toggle" aria-hidden=true > <span class=x-toggle-grid-center data-x-toggle-anim=x-grid-1></span> </span> </span></div> </a></div></div></div></div></div><div class="e154983-13 x-bar x-bar-top x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154983-13&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;50px&quot;} ><div class="e154983-13 x-bar-content"><div class="e154983-14 x-bar-container" ><div class="e154983-15 x-text" > <marquee behavior=scroll direction=left>We are making subtle changes to the site with much more over the summer.  Watch for the new comment sign-up coming soon!</marquee></div></div></div></div></header><div class="x-container max width offset"><div class="x-main full" role=main><article id=post-188400 class="post-188400 post type-post status-publish format-standard has-post-thumbnail hentry category-editorials tag-logan-sagapolu tag-oregon-offensive-line"><div class=entry-featured><div class=entry-thumb><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn2.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video.jpg width=1200 height=630 class="attachment-entry-fullwidth size-entry-fullwidth wp-post-image" alt loading=lazy srcset="https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video.jpg?x46742 1200w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-467x245.jpg?x46742 467w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-762x400.jpg?x46742 762w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-768x403.jpg?x46742 768w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-100x53.jpg?x46742 100w, https://cdn.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-600x315-cropped.jpg?x46742 600w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-800x420.jpg?x46742 800w" sizes="(max-width: 1200px) 100vw, 1200px" data-wp-pid=188402 data-pin-nopin=nopin><noscript><img width=1200 height=630 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20630'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video.jpg class="attachment-entry-fullwidth size-entry-fullwidth wp-post-image lazy" alt loading=lazy data-srcset="https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video.jpg?x46742 1200w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-467x245.jpg?x46742 467w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-762x400.jpg?x46742 762w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-768x403.jpg?x46742 768w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-100x53.jpg?x46742 100w, https://cdn.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-600x315-cropped.jpg?x46742 600w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-800x420.jpg?x46742 800w" data-sizes="(max-width: 1200px) 100vw, 1200px" data-wp-pid=188402 data-pin-nopin=nopin></noscript></div></div><div class=entry-wrap><header class=entry-header><h1 class="entry-title">Oregon&#8217;s BIGGEST Unknown Player for 2021?</h1><p class=p-meta><span><i class=x-icon-pencil data-x-icon-s=&#xf303;></i> Charles Fischer, Mr. FishDuck</span><span><time class=entry-date datetime=2021-07-11T02:05:58-07:00><i class=x-icon-calendar data-x-icon-s=&#xf073;></i> July 11, 2021</time></span><span><a href=https://fishduck.com/category/editorials/ title="View all posts in: &ldquo;Editorials&rdquo;"><i class=x-icon-bookmark data-x-icon-s=&#xf02e;></i> Editorials</a></span><span><a href=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/#comments title="Leave a comment on: &ldquo;Oregon&#8217;s BIGGEST Unknown Player for 2021?&rdquo;" class=meta-comments><i class=x-icon-comments data-x-icon-s=&#xf086;></i> 26 Comments</a></span></p></header><div class="entry-content content"><div class=wpsso-pinterest-pin-it-image style="display:none !important;"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-src=https://cdn.fishduck.com/wp-content/uploads/2021/07/Duck-Huddle-Spring-Game_Pac12-Video-800x420.jpg width=0 height=0 class="skip-lazy lazy" style=width:0;height:0; alt data-pin-description="The Spring Game was certainly a coming-out party for quite a number of freshmen, as we were all impressed with the new players in Robby Ashford, Ty Thompson..."></div><div class="wpsso-rrssb wpsso-rrssb-content" id=wpsso-rrssb-content-post-188400><div class="wpsso-rrssb-limit wpsso-rrssb-content-limit" style="max-width:472px; margin:0 auto;"><ul class="rrssb-buttons en_US clearfix"> <li class=rrssb-facebook> <a href="https://www.facebook.com/sharer/sharer.php?u=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/" class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg preserveAspectRatio=xMidYMid width=29 height=29 viewBox="0 0 29 29"> <path d="M26.4 0H2.6C1.714 0 0 1.715 0 2.6v23.8c0 .884 1.715 2.6 2.6 2.6h12.393V17.988h-3.996v-3.98h3.997v-3.062c0-3.746 2.835-5.97 6.177-5.97 1.6 0 2.444.173 2.845.226v3.792H21.18c-1.817 0-2.156.9-2.156 2.168v2.847h5.045l-.66 3.978h-4.386V29H26.4c.884 0 2.6-1.716 2.6-2.6V2.6c0-.885-1.716-2.6-2.6-2.6z" class=cls-2 fill-rule=evenodd /> </svg> </span> <span class=rrssb-text>facebook</span> </a> </li><li class=rrssb-twitter> <a href="https://twitter.com/intent/tweet?original_referer=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/&url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/&text=Oregon%27s%20BIGGEST%20Unknown%20Player%20for%202021%3F%20%7C%20FishDuck%20%23LoganSagapolu&via=fishduckdotcom" class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M24.253 8.756C24.69 17.08 18.297 24.182 9.97 24.62c-3.122.162-6.22-.646-8.86-2.32 2.702.18 5.375-.648 7.507-2.32-2.072-.248-3.818-1.662-4.49-3.64.802.13 1.62.077 2.4-.154-2.482-.466-4.312-2.586-4.412-5.11.688.276 1.426.408 2.168.387-2.135-1.65-2.73-4.62-1.394-6.965C5.574 7.816 9.54 9.84 13.802 10.07c-.842-2.738.694-5.64 3.434-6.48 2.018-.624 4.212.043 5.546 1.682 1.186-.213 2.318-.662 3.33-1.317-.386 1.256-1.248 2.312-2.4 2.942 1.048-.106 2.07-.394 3.02-.85-.458 1.182-1.343 2.15-2.48 2.71z"/> </svg> </span> <span class=rrssb-text>twitter</span> </a> </li><li class=rrssb-reddit> <a href="http://www.reddit.com/submit?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/&title=Oregon%27s%20BIGGEST%20Unknown%20Player%20for%202021%3F%20%7C%20FishDuck&text=The%20Spring%20Game%20was%20certainly%20a%20coming-out%20party%20for%20quite%20a%20number%20of%20freshmen%2C%20as%20we%20were%20all%20impressed%20with%20the%20new%20players%20in%20Robby%20Ashford%2C%20Ty%20Thompson..."> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M11.794 15.316c0-1.03-.835-1.895-1.866-1.895-1.03 0-1.893.866-1.893 1.896s.863 1.9 1.9 1.9c1.023-.016 1.865-.916 1.865-1.9zM18.1 13.422c-1.03 0-1.895.864-1.895 1.895 0 1 .9 1.9 1.9 1.865 1.03 0 1.87-.836 1.87-1.865-.006-1.017-.875-1.917-1.875-1.895zM17.527 19.79c-.678.68-1.826 1.007-3.514 1.007h-.03c-1.686 0-2.834-.328-3.51-1.005-.264-.265-.693-.265-.958 0-.264.265-.264.7 0 1 .943.9 2.4 1.4 4.5 1.402.005 0 0 0 0 0 .005 0 0 0 0 0 2.066 0 3.527-.46 4.47-1.402.265-.264.265-.693.002-.958-.267-.334-.688-.334-.988-.043z"/> <path d="M27.707 13.267c0-1.785-1.453-3.237-3.236-3.237-.792 0-1.517.287-2.08.76-2.04-1.294-4.647-2.068-7.44-2.218l1.484-4.69 4.062.955c.07 1.4 1.3 2.6 2.7 2.555 1.488 0 2.695-1.208 2.695-2.695C25.88 3.2 24.7 2 23.2 2c-1.06 0-1.98.616-2.42 1.508l-4.633-1.09c-.344-.082-.693.117-.803.454l-1.793 5.7C10.55 8.6 7.7 9.4 5.6 10.75c-.594-.45-1.3-.75-2.1-.72-1.785 0-3.237 1.45-3.237 3.2 0 1.1.6 2.1 1.4 2.69-.04.27-.06.55-.06.83 0 2.3 1.3 4.4 3.7 5.9 2.298 1.5 5.3 2.3 8.6 2.325 3.227 0 6.27-.825 8.57-2.325 2.387-1.56 3.7-3.66 3.7-5.917 0-.26-.016-.514-.05-.768.965-.465 1.577-1.565 1.577-2.698zm-4.52-9.912c.74 0 1.3.6 1.3 1.3 0 .738-.6 1.34-1.34 1.34s-1.343-.602-1.343-1.34c.04-.655.596-1.255 1.396-1.3zM1.646 13.3c0-1.038.845-1.882 1.883-1.882.31 0 .6.1.9.21-1.05.867-1.813 1.86-2.26 2.9-.338-.328-.57-.728-.57-1.26zm20.126 8.27c-2.082 1.357-4.863 2.105-7.83 2.105-2.968 0-5.748-.748-7.83-2.105-1.99-1.3-3.087-3-3.087-4.782 0-1.784 1.097-3.484 3.088-4.784 2.08-1.358 4.86-2.106 7.828-2.106 2.967 0 5.7.7 7.8 2.106 1.99 1.3 3.1 3 3.1 4.784C24.86 18.6 23.8 20.3 21.8 21.57zm4.014-6.97c-.432-1.084-1.19-2.095-2.244-2.977.273-.156.59-.245.928-.245 1.036 0 1.9.8 1.9 1.9-.016.522-.27 1.022-.57 1.327z"/> </svg> </span> <span class=rrssb-text>reddit</span> </a> </li><li class=rrssb-linkedin> <a href="http://www.linkedin.com/shareArticle?mini=true&url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/&title=Oregon%27s%20BIGGEST%20Unknown%20Player%20for%202021%3F%20%7C%20FishDuck&summary=The%20Spring%20Game%20was%20certainly%20a%20coming-out%20party%20for%20quite%20a%20number%20of%20freshmen%2C%20as%20we%20were%20all%20impressed%20with%20the%20new%20players%20in%20Robby%20Ashford%2C%20Ty%20Thompson..." class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M25.424 15.887v8.447h-4.896v-7.882c0-1.98-.71-3.33-2.48-3.33-1.354 0-2.158.91-2.514 1.802-.13.315-.162.753-.162 1.194v8.216h-4.9s.067-13.35 0-14.73h4.9v2.087c-.01.017-.023.033-.033.05h.032v-.05c.65-1.002 1.812-2.435 4.414-2.435 3.222 0 5.638 2.106 5.638 6.632zM5.348 2.5c-1.676 0-2.772 1.093-2.772 2.54 0 1.42 1.066 2.538 2.717 2.546h.032c1.71 0 2.77-1.132 2.77-2.546C8.056 3.593 7.02 2.5 5.344 2.5h.005zm-2.48 21.834h4.896V9.604H2.867v14.73z"/> </svg> </span> <span class=rrssb-text>linkedin</span> </a> </li></ul></div></div><div class=pf-content><p>The Spring Game was certainly a coming-out party for quite a number of freshmen, as we were all impressed with the new players in <strong>Robby Ashford</strong>, <strong>Ty Thompson</strong>, <strong>Dont&#8217;e Thornton</strong> and <strong>Troy Franklin</strong>. I also loved what I noted of the receiving and blocking of the new Tight Ends in <strong>Terrance Ferguson</strong> and <strong>Moliki Matavao</strong>, yet <em>another</em> player caught my eye and while he did not create the big plays, he may be a reason <em><strong>why</strong></em> explosion plays will occur at Autzen in near future.</p><p>Thus know that my definition of the <em>&#8220;Biggest&#8221;</em> unknown player will not be in terms of touchdowns, yards per carry or receiving, as the context in the case for <em>&#8220;Biggest&#8221;</em> is quite literal. <strong>Logan Sagapolu</strong> at 6&#8217;2&#8243; and <strong>345 pounds</strong> has an intriguing future in the interior of the offensive line. He was originally recruited to be a center at Oregon, and I can certainly picture him rooting out even the biggest of <em>Nose Tackles</em> facing him where smaller centers are often driven backward after the snap.</p><div id=attachment_188435 class="wp-caption aligncenter" style="width: 1200px"><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video.jpg loading=lazy class="size-full wp-image-188435" alt width=1200 height=630 data-wp-pid=188435 data-pin-nopin=nopin srcset="https://cdn1.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video.jpg?x46742 1200w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-467x245.jpg?x46742 467w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-762x400.jpg?x46742 762w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-768x403.jpg?x46742 768w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-100x53.jpg?x46742 100w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-600x315.jpg?x46742 600w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-800x420.jpg?x46742 800w" sizes="(max-width: 1200px) 100vw, 1200px"><noscript><img loading=lazy class="size-full wp-image-188435 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20630'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video.jpg alt width=1200 height=630 data-wp-pid=188435 data-pin-nopin=nopin data-srcset="https://cdn1.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video.jpg?x46742 1200w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-467x245.jpg?x46742 467w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-762x400.jpg?x46742 762w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-768x403.jpg?x46742 768w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-100x53.jpg?x46742 100w, https://cdn3.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-600x315.jpg?x46742 600w, https://cdn1.fishduck.com/wp-content/uploads/2021/07/Logan-Sagapolu_Pac12-Video-800x420.jpg?x46742 800w" data-sizes="(max-width: 1200px) 100vw, 1200px"></noscript><p class=attr-credit-text>From Pac-12 Video</p><p class=wp-caption-text>Logan Sagapolu has a wide base ideal at center or guard against big Nose Tackles.</p></div><p>Sagapolu appears to be thick and stout, thus between his size and growing strength, <em>(thanks Coach <strong>Aaron Feld</strong>!)</em> he could truly become an inside road-grader that Coach <strong>Mario Cristobal</strong> lusts for. Yet note he is <strong>not</strong> short at <strong>6&#8217;2</strong>, but the size of those tree-trunk legs and a wide base at the hips seem perfect for the drive blocking he will engage in to create big holes for Oregon running backs. He originally went on a LDS mission after selecting Oregon over his in-state teams of BYU and Utah, and came to Eugene early due to COVID.</p><p><strong>Chris Courtney</strong> of <em>Whole Flock of Ducks</em> gave us <span style="text-decoration: underline;"><a href=https://wholeflockofducks.com/index.php/2019/01/20/what-are-the-ducks-getting-in-logan-sagapolu/ target=_blank rel=noopener><em><strong>this</strong></em></a></span> recruiting analysis back in 2019 when Sagapolu&#8217;s verbal commitment to Oregon was announced.</p><h4><span style="text-decoration: underline;">Notable strengths:</span></h4><ul> <li><strong>Versatility:</strong> Though there are some legit knocks on Sagapolu&#8217;s athleticism, he is capable of filling in and playing virtually any position along the offensive line. An interior line position is where Sagapolu figures to excel, but he does have experience playing tackle as well.</li> <li><strong>Great initial punch:</strong> Strong as an ox, Sagapolu can be a dominant player at the point of attack. His ability to practically eliminate defenders from a play with a single blow is impressive, making him an even more imposing obstacle for those lined up across from him.</li> <li><strong>Plays with a mean streak:</strong> As if tremendous size and strength weren&#8217;t enough, Sagapolu is player who plays with a nasty streak. On film, he appears to be a player who takes great joy in burying his opponents when given the opportunity.</li></ul><p><iframe loading=lazy title="YouTube video player" src=https://www.youtube.com/embed/r_bAsLyGrBo width=900 height=500 frameborder=0 allowfullscreen=allowfullscreen></iframe></p><p>In the clip of one play above, Sagapolu is the right guard, first one to the right of the center, and second one down from the top of the six interior linemen/tight end and he is <strong>No. 61</strong>. His first objective after the snap is to help the center with a double-team on No. 73, the defensive lineman in green. Note how the two drive the defender back, but the power of Sagapolu moves his opponent further inside, thus creating <em>a larger</em> running lane for the running back.</p><p>The next part of the<em> &#8220;combo-block&#8221;</em> for Logan, is after making sure the center is in command of the <em>Nose Tackle</em>&#8211;he then leaves and moves to the second level, moving to block the linebacker as he does wonderfully. The timing of a combo block is tricky; if you leave too early before the center has full control of the defender, then the play gets blown up at the line of scrimmage. Move off the initial block too late and the running back is already past you and the linebacker nails him immediately. Sagapolu&#8217;s timing is perfect, and<em><strong> impressive</strong></em> for a freshman.</p><p>For an old offensive lineman &#8230; seeing that wonderfully executed combo blocking gives me <em>a rush</em>, as this young man is going to be <em><strong>good.&#160;</strong></em>I grant you this is not blocking a <strong>USC</strong> nose tackle or linebacker yet, but Logan has to show mastery at this level <em>first</em>. He has not been spoken of when the discussion is about the young-guns coming up in the offensive line, but he will ultimately become too successful to ignore, and that will bring a smile to the faces of running backs at Oregon.</p><p><em>&#8220;Oh, how we love to ponder about <strong>Our Beloved Ducks</strong>!&#8221;</em></p><p><strong>Charles Fischer&#160; &#160;</strong><em>(Mr. FishDuck)</em><br> Eugene, Oregon<br> <em>Top Photo from <strong>Pac-12 Video</strong></em></p><p><strong><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2018/11/Phil-Anderson_smaller.jpg loading=lazy class="alignleft size-full wp-image-150528" alt width=70 height=79 data-wp-pid=150528 srcset="https://cdn3.fishduck.com/wp-content/uploads/2018/11/Phil-Anderson_smaller.jpg?x46742 70w, https://cdn3.fishduck.com/wp-content/uploads/2018/11/Phil-Anderson_smaller-49x55.jpg?x46742 49w" sizes="(max-width: 70px) 100vw, 70px"><noscript><img loading=lazy class="alignleft size-full wp-image-150528 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2070%2079'%3E%3C/svg%3E" data-src=https://cdn.fishduck.com/wp-content/uploads/2018/11/Phil-Anderson_smaller.jpg alt width=70 height=79 data-wp-pid=150528 data-srcset="https://cdn3.fishduck.com/wp-content/uploads/2018/11/Phil-Anderson_smaller.jpg?x46742 70w, https://cdn3.fishduck.com/wp-content/uploads/2018/11/Phil-Anderson_smaller-49x55.jpg?x46742 49w" data-sizes="(max-width: 70px) 100vw, 70px"></noscript></strong></p><p><strong>Phil Anderson</strong>, the&#160;<em>FishDuck.com</em>&#160;Volunteer editor for this article, is a trial lawyer in Bend Oregon.</p><p>&nbsp;</p><div class="printfriendly pf-button pf-button-content pf-alignright"><a href=# rel=nofollow onclick="window.print(); return false;" title="Printer Friendly, PDF & Email"><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" alt="Print Friendly, PDF &amp; Email"><noscript><img class=lazy style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png alt="Print Friendly, PDF & Email"></noscript></a></div></div><div class=relpost-thumb-wrapper><div class=relpost-thumb-container><h3>Related Articles:</h3><div style="clear: both"></div><div style="clear: both"></div><div class=relpost-block-container><a class=relpost-block-single href=https://fishduck.com/2021/07/cristobals-next-step-after-oregon/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Cristobal's Next Step after Oregon"  style="background: transparent url(https://cdn3.fishduck.com/wp-content/uploads/2020/03/Cristobal-Endgame_KC_FP-150x150.png?x46742) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Cristobal's Next Step after Oregon</div></div></a><a class=relpost-block-single href=https://fishduck.com/2021/07/ducks-becoming-an-it-school-for-o-iineman/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Ducks Becoming an it School for O-Iineman?"  style="background: transparent url(https://cdn3.fishduck.com/wp-content/uploads/2021/07/kelvin.banks_.OL_-150x150.jpg?x46742) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Ducks Becoming an "it" School for O-Iineman?</div></div></a><a class=relpost-block-single href=https://fishduck.com/2021/07/are-the-beavers-poised-to-pass-the-ducks-on-offense/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Are the Beavers Poised to Pass the Ducks on Offense?"  style="background: transparent url(https://cdn2.fishduck.com/wp-content/uploads/2020/11/Snag_3e66f412-150x150.png?x46742) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Are the Beavers Poised to Pass the Ducks on Offense?</div></div></a><a class=relpost-block-single href=https://fishduck.com/2021/07/can-oregon-pull-off-a-shocker-at-the-shoe/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Can Oregon Pull off a Shocker at the 'Shoe?"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2021/07/CJ-Verdell-vs-UCLA_Tom-Corno-150x150.png?x46742) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Can Oregon Pull off a Shocker at the 'Shoe?</div></div></a><a class=relpost-block-single href=https://fishduck.com/2021/07/if-usc-has-outgrown-the-pac-12-what-has-oregon-done/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="If USC Has Outgrown the Pac-12, What Has Oregon Done?"  style="background: transparent url(https://cdn2.fishduck.com/wp-content/uploads/2021/02/Kedon-Slovis_UO-Athletics-150x150.png?x46742) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">If USC Has Outgrown the Pac-12, What Has Oregon Done?</div></div></a><a class=relpost-block-single href=https://fishduck.com/2021/07/regardless-of-herbert-injury-taggart-still-outscores-cristobal/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Despite Herbert Injury, Taggart STILL Outscores Cristobal"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2021/06/Braxton-Burmeister_Kevin-Cline-150x150.jpg?x46742) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Despite Herbert Injury, Taggart STILL Outscores Cristobal</div></div></a></div><div style="clear: both"></div></div></div><div class=saboxplugin-wrap itemtype=http://schema.org/Person itemscope itemprop=author><div class=saboxplugin-gravatar><a href=https://fishduck.com/author/fishduck/ ><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2016/09/Black-shirt-Fischer.jpg alt itemprop=image><noscript><img class=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://cdn.fishduck.com/wp-content/uploads/2016/09/Black-shirt-Fischer.jpg alt itemprop=image></noscript></a></div><div class=saboxplugin-authorname><a href=https://fishduck.com/author/fishduck/ class="vcard author" rel=author itemprop=url><span class=fn itemprop=name>Charles Fischer, Mr. FishDuck</span></a></div><div class=saboxplugin-desc><div itemprop=description><p>Charles Fischer has been an intense fan of the Ducks, a season ticket holder at Autzen Stadium for 35 years and has written reports on football boards for over 23 years. Known as “<strong><em>FishDuck</em></strong>” on those boards, he is acknowledged for providing intense detail in his scrimmage reports and in his Xs and Os play analyses. He and his wife Lois, have a daughter Christine, reside in Eugene Oregon, where he was a Financial Advisor for 36 years and now focuses full-time on Charitable Planned Giving Workshops for churches and non-profit organizations.</p><p>He does not profess to be a coach or analyst, but simply a “hack” that enjoys sharing what he has learned and invites others to correct or add to this body of Oregon Football! <b><a href=http://fishduck.com/fishduck>See More&#8230;</a></b></p></div></div><div class=clearfix></div></div><div class=awac-wrapper><div class="awac widget text-88"><h4 class="widget-title">Articles EVERY DAY Again on FishDuck!</h4><div class=textwidget><p>Our focus is now on this wonderful <em><strong>Oregon Sports Community</strong></em>, and we will have at least a short article every day to begin the <strong>Duck Discussion</strong>.</p><p>You are also welcome to post <em>other</em> current events or items about <em><strong>Our Beloved Ducks</strong></em> in the comments as well.</p><p><a href=https://fishduck.com/posting-rules/ target=_blank rel=noopener><span style="text-decoration: underline;"><strong><em>Our 32 rules </em></strong></span></a>can be summarized to this: 1) <strong>be polite and respectful</strong>, 2) <strong>keep it clean</strong>, and 3) <strong>no reference of <em>any</em> kind to politics.</strong> <em>Easy-peasy!</em></p><p>Take note though, there are <span style="text-decoration: underline;">NO STRIKES</span>, <span style="text-decoration: underline;">NO WARNINGS</span>, and <span style="text-decoration: underline;">NO SLACK</span> given. Violate the rules and you are <em><strong>gone</strong></em>, as this is what <strong>the 99%</strong> who post superb comments want. <em>(The <strong>Ban</strong> could be for weeks, months or permanent)</em></p><p>For the<strong> 1%</strong> out there who do <em><strong>not</strong></em> have <em>impulse-control</em> &#8230; as you write your comment that violates our rules, ask yourself, <em>&#8220;is this worth getting <strong>banned</strong> over?&#8221;</em></p><p><em><strong>FishDuck</strong></em> members&#8230;.we got your back.  <em><strong>No Trolls Allowed!</strong></em></p><p>New at<em><strong> FishDuck</strong></em>? Learn about the site right <a href=https://fishduck.com/what-is-fishduck-com/ target=_blank rel=noopener><span style="text-decoration: underline;"><em><strong>here</strong></em></span></a>!</p></div></div></div></div></div><footer class="entry-footer cf"> <a href=https://fishduck.com/tag/logan-sagapolu/ rel=tag>Logan Sagapolu</a><a href=https://fishduck.com/tag/oregon-offensive-line/ rel=tag>Oregon Offensive Line</a></footer></article><div class=wpdiscuz_top_clearing></div><div id=comments class=comments-area><div id=respond style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div><div id=wpdcom class="wpdiscuz_unauth wpd-default wpd-layout-2 wpd-comments-open"><div class=wc_social_plugin_wrapper></div><div class=wpd-form-wrap><div class=wpd-form-head><div class=wpd-sbs-toggle> <i class="far fa-envelope"></i> <span class=wpd-sbs-title>Subscribe</span> <i class="fas fa-caret-down"></i></div><div class=wpd-auth><div class=wpd-login> <a href="https://fishduck.com/wp-login.php?redirect_to=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F"><i class='fas fa-sign-in-alt'></i> Login</a></div></div></div><div class="wpdiscuz-subscribe-bar wpdiscuz-hidden"><form action="https://fishduck.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method=post id=wpdiscuz-subscribe-form><div class=wpdiscuz-subscribe-form-intro>Notify of</div><div class=wpdiscuz-subscribe-form-option style=width:40%;> <select class=wpdiscuz_select name=wpdiscuzSubscriptionType ><option value=post>new follow-up comments</option><option value=all_comment >new replies to my comments</option> </select></div><div class="wpdiscuz-item wpdiscuz-subscribe-form-email"> <input class=email type=email name=wpdiscuzSubscriptionEmail required=required value placeholder=Email></div><div class=wpdiscuz-subscribe-form-button> <input id=wpdiscuz_subscription_button class=wpd-prim-button type=submit value=&rsaquo; name=wpdiscuz_subscription_button></div> <input type=hidden id=wpdiscuz_subscribe_form_nonce name=wpdiscuz_subscribe_form_nonce value=b59f9b603c><input type=hidden name=_wp_http_referer value=/2021/07/oregons-biggest-unknown-player-for-2021/ ></form></div><div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id=wpd-main-form-wrapper-0_0></div><div id=wpdiscuz_hidden_secondary_form style="display: none;"><div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id=wpd-secondary-form-wrapper-wpdiscuzuniqueid style='display: none;'><div class=wpd-secondary-forms-social-content></div><div class=clearfix></div></div></div><div class=wpd-login-to-comment>Please login to comment</div></div><div id=wpd-threads class=wpd-thread-wrapper><div class=wpd-thread-head><div class="wpd-thread-info " data-comments-count=26> <span class=wpdtc title=26>26</span> Comments</div><div class=wpd-space></div><div class=wpd-thread-filter><div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div><div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div><div class="wpd-filter wpdf-sorting"> <span class="wpdiscuz-sort-button wpdiscuz-date-sort-desc wpdiscuz-sort-button-active" data-sorting=newest>Newest</span> <i class="fas fa-sort-down"></i><div class=wpdiscuz-sort-buttons> <span class="wpdiscuz-sort-button wpdiscuz-date-sort-asc" data-sorting=oldest>Oldest</span> <span class="wpdiscuz-sort-button wpdiscuz-vote-sort-up" data-sorting=by_vote>Most Voted</span></div></div></div></div><div class=wpd-comment-info-bar><div class=wpd-current-view><i class="fas fa-quote-left"></i> Inline Feedbacks</div><div class=wpd-filter-view-all>View all comments</div></div><div class=wpd-thread-list><div id=wpd-comm-11571_0 class='wpd-comment wpd-sticky-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11571 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class=wpd-comment-status><div class=wpd-sticky wpd-tooltip='Sticky Comment Thread'><i class='fas fa-thumbtack' aria-hidden=true></i></div></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=New Recruit Alert! Arkansas Wide Receiver/Track Star... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11571' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 10:25 am"> <i class='far fa-clock' aria-hidden=true></i> 4 hours ago</div></div></div></div><div class=wpd-comment-text><p><strong><em><u>New Recruit Alert!</u></em></strong></p><p>Arkansas Wide Receiver/Track Star <strong>Isaiah Sategna</strong> has verbally committed to Oregon over USC and a host of other schools. He is a 4-Star on both Rivals and 247 and was offered by <strong>NINE</strong> SEC teams along with Penn State, Florida State as well.</p><p><strong><em>ChicoDuck</em></strong> wrote the following on another site, and I wanted to share his expertise here and thank him for it!</p><p>Let&#8217;s take a look at the WR from Arkansas.</p><p>Isaiah Sategna &#8211; 5-foot-11 &amp; 170 pounds</p><p>Parents have a deep background in Track &amp; Field. He himself was Arkansas Gatorade Player of the Year in track after his Freshman Year with strength&#8217;s in 300 Intermediate Hurdles and the Long Jump.</p><p>Fayetteville High School &#8211; Fayetteville, Arkansas<br> Approximately 2,600 kids (7A) Largest Classification in the State. In 2006 Sports Illustrated listed Fayetteville HS a Top-20 ranking as one of the best Athletic Programs in the United States.</p><p>Freshman Tape (2019)</p><ul> <li>Tracks the ball over his shoulder on a Go route, after blowing by the CB for a long TD.</li> <li>Nice Stop &amp; Go. Catches the ball out away from his frame. Not a body catcher.</li> <li>Makes adjustments in the open field after the catch, to defeat the intercept angles of the Safety. Savvy after the catch.</li> <li>He runs crisp routes, especially the lower branches where it&#8217;s most important to create separation. Very little &#8220;rounding off&#8221;. He &#8220;digs &amp; breaks&#8221;.</li> <li>Does a nice job of adjusting to poorly thrown balls (especially at his feet). Doesn&#8217;t give up on the play. Nice radius.</li> <li>Doesn&#8217;t look like a 14 year old out there. Looks like a upper classman.</li></ul><p>Sophomore Year (2020) Didn&#8217;t Play &#8211; Covid19</p><p>Junior Year (2021) Abbreviated Schedule</p><ul> <li>A real threat in the Screen game. Comes back for the ball and is elusive after the catch.</li> <li>Not a Wallflower. Aggressive RAC. Nice stiff arm and pushes for more YAC. Not shy about working in a phone booth.</li> <li>Can adjust to poorly thrown balls. Walks the wall or can go down and play &#8220;Short Stop&#8221;.</li> <li>Creative in the open field after the catch. Looks for the lanes.</li> <li>Plucks/Tucks in a smooth motion. Doesn&#8217;t &#8220;Hop&#8221; at the moment of reception. I only counted one (1) hop in both tapes.</li> <li>Fights through the Press down in the Red Zone and maintains concentration (one handed catch) for the TD while being held.</li> <li>Changes angles/direction with very little gearing down, especially in the Return Game. He&#8217;s a threat on Kickoff Returns.</li></ul><p>Though he played on the Boundary in HS, I doubt that is where he plays in college. His stature (&lt;6&#8217;0) leads me to believe that he&#8217;s a Slot Guy. His speed, elusiveness, route tree, catch radius, and toughness makes him an ideal candidate.<br> A really fine football player and nice addition to the track team.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class='wpd-vote-result wpd-up' title=2>2</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11571_0></div><div id=wpd-comm-11572_11571 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-author"><div id=comment-11572 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/jon-joseph/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg alt="Jon Joseph" srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt='Jon Joseph' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg data-srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/jon-joseph/ rel='noreferrer ugc' target=_blank>Jon Joseph</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Excellent. But is the WR Room big enough? &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11572' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11571> Charles Fischer, Mr. FishDuck </a></div><div class=wpd-comment-date title="July 11, 2021 11:58 am"> <i class='far fa-clock' aria-hidden=true></i> 2 hours ago</div></div></div></div><div class=wpd-comment-text><p>Excellent. But is the WR Room big enough?</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11572_11571></div><div id=wpd-comm-11574_11572 class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11574 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=I was talking to Natalie Liebhaber, an editor at Fis... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11574' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11572> Jon Joseph </a></div><div class=wpd-comment-date title="July 11, 2021 12:15 pm"> <i class='far fa-clock' aria-hidden=true></i> 2 hours ago</div></div></div></div><div class=wpd-comment-text><p>I was talking to <strong>Natalie Liebhaber</strong>, an editor at <strong><em>FishDuck</em></strong> for many years&#8211;she is also a Buckeye.  She told me on the phone recently that, <em>&#8220;Ohio State has taken so many 5-Star receivers lately that there cannot possibly be enough playing time for all.  So we find out later who will transfer out!&#8221;</em></p><p>What a problem to have.</p><p>But with the bigger schools&#8230;that <strong><em>is</em></strong> what they&#8217;re doing now.  Find out who can play and someone is going to transfer&#8211;whoever doesn&#8217;t make it, got injured, etc.</p><p>Oregon could end up with the same scenario on the offensive line someday?</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11574_11572></div></div></div><div id=wpd-comm-11575_11571 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11575 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/haywarduck/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn3.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg alt=Haywarduck srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt=Haywarduck src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg data-srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/haywarduck/ rel='noreferrer ugc' target=_blank>Haywarduck</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Another one of the boxes I was waiting to check off ... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11575' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11571> Charles Fischer, Mr. FishDuck </a></div><div class=wpd-comment-date title="July 11, 2021 12:33 pm"> <i class='far fa-clock' aria-hidden=true></i> 1 hour ago</div></div></div></div><div class=wpd-comment-text><p>Another one of the boxes I was waiting to check off for the Cristobal era, track speed is coming back!</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11575_11571></div><div id=wpd-comm-11576_11575 class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11576 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=And YOUR name may have had a BIG part of it.   If yo... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11576' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11575> Haywarduck </a></div><div class=wpd-comment-date title="July 11, 2021 12:51 pm"> <i class='far fa-clock' aria-hidden=true></i> 1 hour ago</div></div></div></div><div class=wpd-comment-text><p>And YOUR name may have had a BIG part of it.   If you run track&#8230;how can you <strong><em>NOT</em></strong> want to run here?</p><div class=wmu-comment-attachments><div class='wmu-attached-images wmu-count-single'><div class='wmu-attachment wmu-attachment-188603'><a href=https://cdn1.fishduck.com/wp-content/uploads/2021/07/Hayward-Field-Opening_Bruce-Nelson-1626033082.5263.jpg class='wmu-attached-image-link wmu-lightbox'><img style=max-width:520px;width:520px;height:auto; alt='Hayward Field Opening_Bruce Nelson.jpg' title='Hayward Field Opening_Bruce Nelson.jpg' id=wmu-attachemnt-188603 class='attachment-medium size-medium wmu-attached-image' src=https://cdn3.fishduck.com/wp-content/uploads/2021/07/Hayward-Field-Opening_Bruce-Nelson-1626033082.5263-467x245.jpg wmu-data-src height=auto></a><div class=wmu-separator></div></div></div></div></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11576_11575></div></div></div></div><div id=wpd-comm-11568_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11568 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='Santa Rosa Duck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn.fishduck.com/wp-content/uploads/2021/06/1994-Helmet-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Santa Rosa Duck</div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Hey Charles, great wake up article for this Sunday. ... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11568' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 10:02 am"> <i class='far fa-clock' aria-hidden=true></i> 4 hours ago</div></div></div></div><div class=wpd-comment-text><p>Hey Charles, great wake up article for this Sunday. I love the term &#8220;Road Grader&#8221;. Thanks for the reference to &#8220;Whole Flock of Ducks&#8221;. I always enjoyed his review of new recruits but there has not been an update since June 5. Do you know what happened to Chris Courtney?</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11568_0></div><div id=wpd-comm-11569_11568 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11569 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Chris is realizing what I and others have, and that ... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11569' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11568> Santa Rosa Duck </a></div><div class=wpd-comment-date title="July 11, 2021 10:19 am"> <i class='far fa-clock' aria-hidden=true></i> 4 hours ago</div></div></div></div><div class=wpd-comment-text><p>Chris is realizing what I and others have, and that is the challenge of running a website and having daily content is a monumental job that has few monetization opportunities.  His articles, like mine, are fun to read and informative&#8211;but not enough to charge people a subscription.</p><p>Thus he has been writing for <a href=https://sportspac12.com/ target=_blank rel="noopener nofollow ugc"><strong><em>SportsPac12</em></strong></a> and I suspect it will become permanent.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class='wpd-vote-result wpd-up' title=1>1</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11569_11568></div></div></div><div id=wpd-comm-11555_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-author"><div id=comment-11555 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/jon-joseph/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg alt="Jon Joseph" srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt='Jon Joseph' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg data-srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/jon-joseph/ rel='noreferrer ugc' target=_blank>Jon Joseph</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Great info backed by great video. Thank you Charles.... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11555' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 8:02 am"> <i class='far fa-clock' aria-hidden=true></i> 6 hours ago</div></div></div></div><div class=wpd-comment-text><p>Great info backed by great video. Thank you Charles.</p><p>Logan Sagapolu arrived in Eugene in 2020. With the COVID-added additional season of eligibility I believe, roster-wise, that he will be a &#8216;true frosh&#8217; in 2021.</p><p>Am I correct in this assumption? If so, he could play through the 2024 season. When he&#8217;ll be how big?</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11555_0></div><div id=wpd-comm-11559_11555 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11559 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=He is a true freshman right now, yes.  He was actual... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11559' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11555> Jon Joseph </a></div><div class=wpd-comment-date title="July 11, 2021 8:27 am"> <i class='far fa-clock' aria-hidden=true></i> 6 hours ago</div></div></div></div><div class=wpd-comment-text><p>He is a true freshman right now, yes.  He was actually 355 when he was signed in 2019, and I assume that he could still lose a little and still be bigger than most Nose Tackles on defense!</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class='wpd-vote-result wpd-up' title=1>1</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11559_11555></div><div id=wpd-comm-11566_11559 class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-author"><div id=comment-11566 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/jon-joseph/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg alt="Jon Joseph" srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt='Jon Joseph' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg data-srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/jon-joseph/ rel='noreferrer ugc' target=_blank>Jon Joseph</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Thank you Sir. &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11566' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11559> Charles Fischer, Mr. FishDuck </a></div><div class=wpd-comment-date title="July 11, 2021 8:45 am"> <i class='far fa-clock' aria-hidden=true></i> 5 hours ago</div></div></div></div><div class=wpd-comment-text><p>Thank you Sir.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11566_11559></div></div></div></div><div id=wpd-comm-11554_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11554 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt=ImOldGreg89 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2021/07/Screenshot_20210226-193507_Facebook-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> ImOldGreg89</div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=I didn&#8217;t think we would ever see another start... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11554' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 7:40 am"> <i class='far fa-clock' aria-hidden=true></i> 6 hours ago</div></div></div></div><div class=wpd-comment-text><p>I didn&#8217;t think we would ever see another starting line that could hold a candle to the line featuring Penei Sewell, Shane Lemieux, Jake Hanson, Dallas Warmack, Doc Throck/ Brady Aiello&#8230; Boy, did I ever underestimate M.C. and his baby Big Uglies. The potential of our current offensive line room is as good, if not better than, any other program in the nation. I was always pretty high on Sagapolu out of high school, his frame and style really reminded me of Dallas Warmack. Go Ducks!</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11554_0></div><div id=wpd-comm-11560_11554 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11560 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=ImOldGreg&#8230;.your first post and I hope you will... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11560' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11554> ImOldGreg89 </a></div><div class=wpd-comment-date title="July 11, 2021 8:28 am"> <i class='far fa-clock' aria-hidden=true></i> 6 hours ago</div></div></div></div><div class=wpd-comment-text><p><strong><em>ImOldGreg</em></strong>&#8230;.your first post and I hope you will share your thoughts <em>often</em>. <strong>WELCOME!</strong></p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11560_11554></div></div></div><div id=wpd-comm-11553_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11553 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/haywarduck/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn3.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg alt=Haywarduck srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt=Haywarduck src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg data-srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/haywarduck/ rel='noreferrer ugc' target=_blank>Haywarduck</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Too funny, great title, the biggest unknown players ... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11553' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 6:37 am"> <i class='far fa-clock' aria-hidden=true></i> 7 hours ago</div></div></div></div><div class=wpd-comment-text><p>Too funny, great title, the biggest unknown players are always the O-line.</p><p>The biggest unknown player last year was a walk-on with a stache. This year it will be a walk-on, who is moving up the depth chart, from Scappoose. Nobody knows who he is, but they will by the end of the season, much like Henry.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11553_0></div><div id=wpd-comm-11556_11553 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-author"><div id=comment-11556 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/jon-joseph/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg alt="Jon Joseph" srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt='Jon Joseph' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg data-srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/jon-joseph/ rel='noreferrer ugc' target=_blank>Jon Joseph</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=But if he moves up, he will no longer be the Caboose... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11556' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11553> Haywarduck </a></div><div class=wpd-comment-date title="July 11, 2021 8:04 am"> <i class='far fa-clock' aria-hidden=true></i> 6 hours ago</div></div></div></div><div class=wpd-comment-text><p>But if he moves up, he will no longer be the Caboose from Scappoose? [SORRY!]</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11556_11553></div><div id=wpd-comm-11567_11556 class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11567 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/haywarduck/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn3.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg alt=Haywarduck srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt=Haywarduck src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg data-srcset="https://cdn1.fishduck.com/wp-content/uploads/2020/07/New-Hayward-Field-Illustration_around.uoregon.edu_.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/haywarduck/ rel='noreferrer ugc' target=_blank>Haywarduck</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Just the kid from Scappose on the loose, running lik... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11567' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11556> Jon Joseph </a></div><div class=wpd-comment-date title="July 11, 2021 8:56 am"> <i class='far fa-clock' aria-hidden=true></i> 5 hours ago</div></div></div></div><div class=wpd-comment-text><p>Just the kid from Scappose on the loose, running like a moose, going vamoose!</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11567_11556></div><div id=wpd-comm-11573_11567 class='wpd-comment wpd-reply wpd_comment_level-4'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-author"><div id=comment-11573 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/jon-joseph/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg alt="Jon Joseph" srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt='Jon Joseph' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg data-srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/jon-joseph/ rel='noreferrer ugc' target=_blank>Jon Joseph</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=YES! &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11573' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11567> Haywarduck </a></div><div class=wpd-comment-date title="July 11, 2021 11:59 am"> <i class='far fa-clock' aria-hidden=true></i> 2 hours ago</div></div></div></div><div class=wpd-comment-text><p>YES!</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11573_11567></div></div></div></div><div id=wpd-comm-11561_11553 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11561 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Interesting&#8230;.as it does not take long to go to... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11561' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11553> Haywarduck </a></div><div class=wpd-comment-date title="July 11, 2021 8:34 am"> <i class='far fa-clock' aria-hidden=true></i> 5 hours ago</div></div></div></div><div class=wpd-comment-text><p>Interesting&#8230;.as it does not take long to go to the roster at GoDucks.com and find a sophomore receiver, <strong>Tevin Jeannis</strong>, from <em>Scappoose. </em>He is<strong> 6&#8217;3&#8243;</strong> and <strong>192 lbs</strong>&#8230;..hmmmm, as he could do well blocking DBs and LBs in addition to receiving.</p><p>And an Oregon lad to boot; nice catch, and THANKS.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11561_11553></div></div></div><div id=wpd-comm-11552_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11552 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt=smith72 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/05/20190311_061956-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> smith72</div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Good analysis Charles!  That was an awesome punch on... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11552' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 6:30 am"> <i class='far fa-clock' aria-hidden=true></i> 8 hours ago</div></div></div></div><div class=wpd-comment-text><p>Good analysis Charles!  That was an awesome punch on the linebacker!  Nice to have more fresh legs to rotate on the line.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11552_0></div><div id=wpd-comm-11562_11552 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11562 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=We have had freshmen start on the offensive line or ... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11562' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11552> smith72 </a></div><div class=wpd-comment-date title="July 11, 2021 8:35 am"> <i class='far fa-clock' aria-hidden=true></i> 5 hours ago</div></div></div></div><div class=wpd-comment-text><p>We have had freshmen start on the offensive line or come in and play extensive minutes due to injury in the past&#8211;I just thought bringing him to everyone&#8217;s attention would be fun.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class='wpd-vote-result wpd-up' title=1>1</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11562_11552></div></div></div><div id=wpd-comm-11551_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11551 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/pittduck/ target=_blank rel='noreferrer ugc'><img alt=PittDuck src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2020/07/F51D4416-6E74-4ABD-A306-49C53DDA962E-64x64.jpeg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/pittduck/ rel='noreferrer ugc' target=_blank>PittDuck</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Too Good To Be Ignored!  Something all young Ducks s... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11551' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 6:25 am"> <i class='far fa-clock' aria-hidden=true></i> 8 hours ago</div></div></div></div><div class=wpd-comment-text><p>Too Good To Be Ignored!  Something all young Ducks should strive for.  I am so looking forward to watching Logan and the entire flock of Ducks show the nation that they are too good to be ignored.</p><p>I am looking forward to watching our O-line roadgraders and our D-line wrecking balls wreak havoc on their opponents! The upcoming season is high time to unleash the Ducks!</p><p>Just the thought of those ESPN / SEC wonks having to admit on air how good the Ducks are playing, brings a smile to my face!</p><p>Thanks Charles, for getting my morning off to a good start!  I think I’ll take the grandkids to the beach and beat the heat.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class='wpd-vote-result wpd-up' title=1>1</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11551_0></div><div id=wpd-comm-11557_11551 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-author"><div id=comment-11557 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/jon-joseph/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg alt="Jon Joseph" srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt='Jon Joseph' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg data-srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/jon-joseph/ rel='noreferrer ugc' target=_blank>Jon Joseph</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=ESPN &#8211; will possibly admit it if Oregon defeat... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11557' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11551> PittDuck </a></div><div class=wpd-comment-date title="July 11, 2021 8:07 am"> <i class='far fa-clock' aria-hidden=true></i> 6 hours ago</div></div></div></div><div class=wpd-comment-text><p>ESPN &#8211; will possibly admit it if Oregon defeats Ohio State?</p><p>SEC fans won&#8217;t admit it unless Oregon defeats Georgia in 2022. And then the appreciation will come with some kind of excuse for UGA&#8217;s poor play.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class='wpd-vote-result wpd-up' title=1>1</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11557_11551></div></div><div id=wpd-comm-11563_11551 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11563 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Thank you, and when he fires out low&#8211;his lever... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11563' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11551> PittDuck </a></div><div class=wpd-comment-date title="July 11, 2021 8:36 am"> <i class='far fa-clock' aria-hidden=true></i> 5 hours ago</div></div></div></div><div class=wpd-comment-text><p>Thank you, and when he fires out low&#8211;his leverage would be amazing, and I cannot help but wonder how defensive linemen would negate his block&#8230;.once he has<em> &#8220;the Oregon Way&#8221;</em> down?</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11563_11551></div></div></div><div id=wpd-comm-11550_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-um_forum-user"><div id=comment-11550 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt=Quackanadian src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Tight-White-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Quackanadian</div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=The Ducks finally have some Wisconsin level beef on ... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11550' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="July 11, 2021 5:23 am"> <i class='far fa-clock' aria-hidden=true></i> 9 hours ago</div></div></div></div><div class=wpd-comment-text><p>The Ducks finally have some Wisconsin level beef on the O-Line. Let&#8217;s just hope MC doesn&#8217;t keep wanting to run the Wisconsin power I offence! Hahahaha&#8230;.</p><p>Good read Charles! Cheers!</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class='wpd-vote-result wpd-up' title=1>1</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11550_0></div><div id=wpd-comm-11558_11550 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-author"><div id=comment-11558 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/jon-joseph/ target=_blank rel='noreferrer ugc'><img src=https://cdn2.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?x46742 data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg alt="Jon Joseph" srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class="avatar avatar-64 photo sab-custom-avatar" height=64 width=64 data-pin-nopin=nopin><noscript><img alt='Jon Joseph' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn1.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg data-srcset="https://cdn2.fishduck.com/wp-content/uploads/2021/05/Jon-Joseph.jpg?x46742 2x" class='avatar avatar-64 photo sab-custom-avatar lazy' height=64 width=64 data-pin-nopin=nopin></noscript></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/jon-joseph/ rel='noreferrer ugc' target=_blank>Jon Joseph</a></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Maybe, if Wisconsin-like RBs were on the roster this... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11558' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11550> Quackanadian </a></div><div class=wpd-comment-date title="July 11, 2021 8:08 am"> <i class='far fa-clock' aria-hidden=true></i> 6 hours ago</div></div></div></div><div class=wpd-comment-text><p>Maybe, if Wisconsin-like RBs were on the roster this wouldn&#8217;t be a terrible idea?</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-11558_11550></div><div id=wpd-comm-11565_11558 class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11565 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=You&#8217;re killing me Jon, as I think of the high ... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11565' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11558> Jon Joseph </a></div><div class=wpd-comment-date title="July 11, 2021 8:38 am"> <i class='far fa-clock' aria-hidden=true></i> 5 hours ago</div></div></div></div><div class=wpd-comment-text><p>You&#8217;re killing me Jon, as I think of the high level of running backs that have been at Wisconsin.  Why can&#8217;t we get a sniff from the best RBs now, I wonder&#8230;.?</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11565_11558></div></div></div><div id=wpd-comm-11564_11550 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-11564 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <a href=https://fishduck.com/author/fishduck/ target=_blank rel='noreferrer ugc'><img alt='Charles Fischer, Mr. FishDuck' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src=https://cdn3.fishduck.com/wp-content/uploads/2021/06/2013-Green-C-64x64.jpg class='avatar avatar-64 photo avatar-default lazy' height=64 width=64></a></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> <a href=https://fishduck.com/author/fishduck/ rel='noreferrer ugc' target=_blank>Charles Fischer, Mr. FishDuck</a></div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top"> <i class='fas fa-share-alt' aria-hidden=true></i><div class=wpd-tooltip-content> <a class=wc_tw rel=noreferrer target=_blank href='https://twitter.com/intent/tweet?text=Good call, as this young fellow may not be the faste... &url=https%3A%2F%2Ffishduck.com%2F2021%2F07%2Foregons-biggest-unknown-player-for-2021%2F%23comment-11564' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden=true></i></a><a class=wc_vk rel=noreferrer target=_blank href='https://vk.com/share.php?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden=true></i></a><a class=wc_ok rel=noreferrer target=_blank href='https://connect.ok.ru/offer?url=https://fishduck.com/2021/07/oregons-biggest-unknown-player-for-2021/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden=true></i></a></div></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-11550> Quackanadian </a></div><div class=wpd-comment-date title="July 11, 2021 8:37 am"> <i class='far fa-clock' aria-hidden=true></i> 5 hours ago</div></div></div></div><div class=wpd-comment-text><p><strong>Good call</strong>, as this young fellow may not be the fastest or most agile&#8211;but a classic road-grader in the Wisconsin mold as you noted.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked wpd-dislike-hidden"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-11564_11550></div></div></div><div class=wpdiscuz-comment-pagination></div></div></div></div></div><div id=wpdiscuz-loading-bar class=wpdiscuz-loading-bar-unauth></div><div id=wpdiscuz-comment-message class=wpdiscuz-comment-message-unauth></div></div></div><footer class=x-colophon role=contentinfo ><div class="e154993-1 x-bar x-bar-footer x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154993-1&quot;,&quot;region&quot;:&quot;footer&quot;,&quot;height&quot;:&quot;auto&quot;} ><div class="e154993-1 x-bar-content"><div class="e154993-2 x-bar-container" > <a class="e154993-3 x-image" href=https://fishduck.com > <img class=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20225%2059'%3E%3C/svg%3E" data-src=https://cdn2.fishduck.com/wp-content/uploads/2020/12/FishDuck-Community-Logo.png width=225 height=59.5 alt="Fish Duck" loading=lazy> </a></div><div class="e154993-4 x-bar-container" > <a class="e154993-5 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=https://www.facebook.com/FishDuckOnline/ ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf09a; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-6 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=https://twitter.com/fishduckdotcom ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf099; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-7 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=https://www.youtube.com/user/FishDuck83 ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf167; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a></div><div class="e154993-8 x-bar-container" ><ul class="e154993-9 x-menu x-menu-inline x-menu-first-level" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154994" id=menu-item-154994 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184839" id=menu-item-184839 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://forum.fishduck.com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Our Beloved Ducks Forum</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154995" id=menu-item-154995 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Commenting Rules" href=https://fishduck.com/commenting-rules/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Posting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154996" id=menu-item-154996 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154997" id=menu-item-154997 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul></div><div class="e154993-10 x-bar-container" ><form class="e154993-11 x-search" data-x-search={&quot;search&quot;:true} action=https://fishduck.com/ method=get ><label class=visually-hidden for=s-e154993-11 >Search</label><input id=s-e154993-11 class=x-search-input type=search name=s value tabindex=0 placeholder=Search> <button class="x-search-btn x-search-btn-submit" type=button data-x-search-submit tabindex=0 ><span class=visually-hidden>Submit</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><circle fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 cx=10 cy=10 r=9 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=22 y1=22 x2=16.4 y2=16.4 stroke-linejoin=miter /></svg></button> <button class="x-search-btn x-search-btn-clear" type=button data-x-search-clear tabindex=0 ><span class=visually-hidden>Clear</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=5 x2=5 y2=19 stroke-linejoin=miter /><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=19 x2=5 y2=5 stroke-linejoin=miter /></svg></button></form></div></div></div><div class="e154993-12 x-bar x-bar-footer x-bar-h x-bar-relative  x-hide-xl x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154993-12&quot;,&quot;region&quot;:&quot;footer&quot;,&quot;height&quot;:&quot;auto&quot;} ><div class="e154993-12 x-bar-content"><div class="e154993-13 x-bar-container" > <span class="e154993-14 x-image" > <img class=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20231%2040'%3E%3C/svg%3E" data-src=https://cdn.fishduck.com/wp-content/uploads/2019/04/FishDuck_Logo.png width=231.5 height=40 alt=Image loading=lazy> </span></div><div class="e154993-15 x-bar-container" > <a class="e154993-16 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf09a; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-17 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf099; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-18 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf167; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a></div><div class="e154993-19 x-bar-container" ><ul class="e154993-20 x-menu x-menu-inline x-menu-first-level" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154994" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184839" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://forum.fishduck.com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Our Beloved Ducks Forum</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154995" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Commenting Rules" href=https://fishduck.com/commenting-rules/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Posting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154996" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154997" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul></div><div class="e154993-21 x-bar-container" ><form class="e154993-22 x-search" data-x-search={&quot;search&quot;:true} action=https://fishduck.com/ method=get ><label class=visually-hidden for=s-e154993-22 >Search</label><input id=s-e154993-22 class=x-search-input type=search name=s value tabindex=0 placeholder=Search> <button class="x-search-btn x-search-btn-submit" type=button data-x-search-submit tabindex=0 ><span class=visually-hidden>Submit</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><circle fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 cx=10 cy=10 r=9 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=22 y1=22 x2=16.4 y2=16.4 stroke-linejoin=miter /></svg></button> <button class="x-search-btn x-search-btn-clear" type=button data-x-search-clear tabindex=0 ><span class=visually-hidden>Clear</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=5 x2=5 y2=19 stroke-linejoin=miter /><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=19 x2=5 y2=5 stroke-linejoin=miter /></svg></button></form></div></div></div></footer><div id=e154983-6-off-canvas class="e154983-6 x-off-canvas x-off-canvas-right  x-hide-lg x-hide-md x-hide-sm x-hide-xl" role=dialog tabindex=-1 data-x-toggleable=e154983-6 aria-hidden=true aria-label="Off Canvas" ><span class=x-off-canvas-bg></span><button class="x-off-canvas-close x-off-canvas-close-right" data-x-toggle-close=1 aria-label="Close Off Canvas Content" > <span>&times;</span> </button><div class="x-off-canvas-content x-off-canvas-content-right" data-x-scrollbar={&quot;suppressScrollX&quot;:true} role=document aria-label="Off Canvas Content" ><ul class="e154983-6 x-menu x-menu-collapsed" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154985" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154986" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154987" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154988" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=Contact href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li></ul></div></div><div id=e154983-12-off-canvas class="e154983-12 x-off-canvas x-off-canvas-right" role=dialog tabindex=-1 data-x-toggleable=e154983-12 aria-hidden=true aria-label="Off Canvas" ><span class=x-off-canvas-bg></span><button class="x-off-canvas-close x-off-canvas-close-right" data-x-toggle-close=1 aria-label="Close Off Canvas Content" > <span>&times;</span> </button><div class="x-off-canvas-content x-off-canvas-content-right" data-x-scrollbar={&quot;suppressScrollX&quot;:true} role=document aria-label="Off Canvas Content" ><ul class="e154983-12 x-menu x-menu-collapsed" ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-178454" id=menu-item-178454 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Home</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178451" id=menu-item-178451 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/posting-rules/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Posting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178452" id=menu-item-178452 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178453" id=menu-item-178453 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-178450" id=menu-item-178450 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/about/ id=x-menu-collapsed-anchor-e154983-12-0 data-x-toggle=collapse data-x-toggleable=e154983-12-0 aria-controls=x-menu-collapsed-list-e154983-12-0 aria-expanded=false aria-haspopup=true aria-label="Toggle Collapsed Sub Menu" ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a><ul class="sub-menu x-collapsed" id=x-menu-collapsed-list-e154983-12-0 aria-hidden=true aria-labelledby=x-menu-collapsed-anchor-e154983-12-0 data-x-toggleable=e154983-12-0 data-x-toggle-collapse=1 ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184103" id=menu-item-184103 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/terms-of-service/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Terms of Service</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184102" id=menu-item-184102 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/privacy-policy/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Privacy Policy</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178455" id=menu-item-178455 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/the-oregon-football-repository-by-fishduck-com/the-oregon-football-analysis-library-by-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Analysis Library</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178456" id=menu-item-178456 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/2017/10/building-an-oregon-football-repository-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Football Repository</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178457" id=menu-item-178457 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/join-fishduck-com-main-page/student-internship-opportunities-at-fishduck-com/sports-reporter-internship/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Top Photo Credit</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-182576" id=menu-item-182576 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/fishletter/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Newsletter Sign-up</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186265" id=menu-item-186265 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/account/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >My FishDuck Account</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179913" id=menu-item-179913 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/login/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Log In</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179915" id=menu-item-179915 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/logout/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Log Out</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li></ul></div></div></div> <a class="x-scroll-top right fade" title="Back to Top"> <i class=x-icon-angle-up data-x-icon-s=&#xf106;></i> </a> <script>jQuery(document).ready(function($){var $window=$(window);var body=$('body');var bodyOffsetBottom=$window.scrollBottom();var bodyHeightAdjustment=body.height()-bodyOffsetBottom;var bodyHeightAdjusted=body.height()-bodyHeightAdjustment;var $scrollTopAnchor=$('.x-scroll-top');function sizingUpdate(){var bodyOffsetTop=$window.scrollTop();if(bodyOffsetTop>(bodyHeightAdjusted*0.75)){$scrollTopAnchor.addClass('in');}else{$scrollTopAnchor.removeClass('in');}}$window.on('scroll',sizingUpdate).resize(sizingUpdate);sizingUpdate();$scrollTopAnchor.on('click',function(){$('html, body').animate({scrollTop:0},850,'xEaseInOutExpo');return false;});});</script> </div><a href=javascript:void(0); id=wpdUserContentInfoAnchor style=display:none; rel=#wpdUserContentInfo data-wpd-lity>wpDiscuz</a><div id=wpdUserContentInfo style=overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px; class=lity-hide></div><div id=wpd-editor-source-code-wrapper-bg></div><div id=wpd-editor-source-code-wrapper><textarea id=wpd-editor-source-code></textarea><button id=wpd-insert-source-code>Insert</button><input type=hidden id=wpd-editor-uid></div> <script id=pf_script>var pfHeaderImgUrl='';var pfHeaderTagline='';var pfdisableClickToDel='0';var pfImagesSize='full-size';var pfImageDisplayStyle='right';var pfEncodeImages='0';var pfDisableEmail='0';var pfDisablePDF='0';var pfDisablePrint='0';var pfCustomCSS='';var pfPlatform='WordPress';</script> <script async src=https://cdn.printfriendly.com/printfriendly.js></script> <div class=wpdiscuz-fem-email style='display: none;'></div><div class=wpdiscuz-fem-email-form style='display: none;'><span class=wpdiscuz-fem-author>You are going to send email to <em></em></span><i class='fas fa-times'></i><div class=wpdiscuz_clear></div><input placeholder='Email Subject' type=text class=wpdiscuz-fem-subj value><textarea class=wpdiscuz-fem-msg placeholder='Enter your message here'></textarea><br><div class=wpdiscuz-fem-button-align><button type=button class=wpdiscuz-fem-send>Send</button></div><input type=hidden id=wpdiscuz_fem_email_comment_id></div><div class=wpdiscuz-fem-moving style='display: none;'></div><div class=wpdiscuz-fem-move-form style='display: none;'><span class=wpdiscuz-fem-author>Move Comment<br><em></em></span><i class='fas fa-times'></i><div class=wpdiscuz_clear></div><div class=wpdiscuz-fem-posts-search><input type=text class=wpdiscuz-fem-post placeholder='Enter post title...'><div class=wpdiscuz-fem-posts></div></div><div class=wpdiscuz-fem-button-align><button type=button class=wpdiscuz-fem-move>Move</button></div><input type=hidden id=wpdiscuz_fem_move_comment_id></div><script src=https://cdn1.fishduck.com/wp-content/themes/pro/cornerstone/assets/dist/js/site/cs.ad0155b.js?x46742 id=cornerstone-site-body-js></script> <script id=wpdiscuz-combo-js-js-extra>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</script> <script id=wpdiscuz-combo-js-js-before>var wpdiscuzEditorOptions={modules:{toolbar:"",counter:{uniqueID:"",commentmaxcount:0,replymaxcount:0,commentmincount:1,replymincount:1,},},wc_be_the_first_text:"Be the First to Comment!",wc_comment_join_text:"Join the discussion",theme:'snow',debug:'error'};</script> <script src='https://cdn1.fishduck.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js?x46742' id=wpdiscuz-combo-js-js></script> <script src='https://cdn1.fishduck.com/wp-content/themes/pro/framework/dist/js/site/x.js?x46742' id=x-site-js></script> <script src='https://cdn1.fishduck.com/wp-includes/js/comment-reply.min.js?x46742' id=comment-reply-js></script> <script src='https://cdn1.fishduck.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?x46742' id=jquery-sonar-js></script> <script src='https://cdn1.fishduck.com/wp-content/plugins/lazy-load/js/lazy-load.js?x46742' id=wpcom-lazy-load-images-js></script> <script src='https://cdn1.fishduck.com/wp-content/plugins/wpsso-rrssb/js/ext/rrssb.min.js?x46742' id=rrssb-js></script> <script src='https://cdn1.fishduck.com/wp-includes/js/wp-embed.min.js?x46742' id=wp-embed-js></script> <script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script async src=https://cdn1.fishduck.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js?x46742></script></body></html>