<!DOCTYPE html><html class=no-js lang=en-US prefix="og: https://ogp.me/ns# fb: https://ogp.me/ns/fb# article: https://ogp.me/ns/article#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel=pingback href=https://fishduck.com/xmlrpc.php><title>Oregon&#8217;s Most Successful NFL Draft Pick Players | FishDuck</title><meta name="description" content="The Draft is one of the most important moments in the entire NFL calendar, as it allows teams the chance to scoop up some of the best talent from schools across&#8230;"><link rel=canonical href=https://fishduck.com/2022/01/oregons-most-successful-nfl-draft-pick-players/ ><link rel=alternate type=application/rss+xml title="FishDuck &raquo; Feed" href=https://fishduck.com/feed/ ><link rel=stylesheet href=https://cdn.fishduck.com/wp-content/cache/minify/a5ff7.css media=all><style id=wp-block-library-theme-inline-css>#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}</style><link rel=stylesheet href=https://cdn.fishduck.com/wp-content/cache/minify/76ad4.css media=all> <script src=https://cdn.fishduck.com/wp-content/cache/minify/818c0.js></script> <link rel=https://api.w.org/ href=https://fishduck.com/wp-json/ ><link rel=alternate type=application/json href=https://fishduck.com/wp-json/wp/v2/posts/193142> <script>_atrk_opts={atrk_acct:"O+dIk1ao6C52O7",domain:"fishduck.com",dynamic:true};(function(){var as=document.createElement('script');as.type='text/javascript';as.async=true;as.src="https://certify-js.alexametrics.com/atrk.js";var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as,s);})();</script> <noscript><img src="https://certify.alexametrics.com/atrk.gif?account=O+dIk1ao6C52O7" style=display:none height=1 width=1 alt></noscript><meta property="fb:pages" content="266952793316048">  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-24966687-1"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-24966687-1');</script> <style>@media screen{.printfriendly{position:relative;z-index:1000;margin:12px 12px 12px 12px                     }.printfriendly a, .printfriendly a:link, .printfriendly a:visited, .printfriendly a:hover, .printfriendly a:active{font-weight:600;cursor:pointer;text-decoration:none;border:none;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;outline:none;font-size:14px !important;color:#6D9F00 !important}.printfriendly.pf-alignleft{float:left}.printfriendly.pf-alignright{float:right}.printfriendly.pf-aligncenter{display:flex;align-items:center;justify-content:center}}}@media print{.printfriendly{display:none}}.pf-button.pf-button-excerpt{display:none}.pf-button-img{border:none;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;padding:0;margin:0;display:inline;vertical-align:middle}img.pf-button-img+.pf-button-text{margin-left:6px}</style><style>#related_posts_thumbnails li{border-right:1px solid #ddd;background-color:#fff}#related_posts_thumbnails li:hover{background-color:#eee}.relpost_content{font-size:12px;color:#333}.relpost-block-single{background-color:#fff;border-right:1px solid  #ddd;border-left:1px solid  #ddd;margin-right:-1px}.relpost-block-single:hover{background-color:#eee}</style><meta name="wpsso-begin" content="wpsso meta tags and schema markup begin"><meta name="generator" content="WPSSO Core 9.13.1/L*"><meta name="generator" content="WPSSO RRSSB 8.2.0/S"><meta name="generator" content="WPSSO UM 4.10.2/S"><link rel=shortlink href="https://fishduck.com/?p=193142"><meta property="fb:app_id" content="146912038807686"><meta property="og:type" content="article"><meta property="og:url" content="https://fishduck.com/2022/01/oregons-most-successful-nfl-draft-pick-players/"><meta property="og:locale" content="en_US"><meta property="og:site_name" content="FishDuck"><meta property="og:title" content="Oregon&#039;s Most Successful NFL Draft Pick Players | FishDuck"><meta property="og:description" content="The Draft is one of the most important moments in the entire NFL calendar, as it allows teams the chance to scoop up some of the best talent from schools across..."><meta property="og:updated_time" content="2022-01-08T18:25:32+00:00"><meta property="og:image" content="https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-762x400.jpg"><meta property="og:image:width" content="762"><meta property="og:image:height" content="400"><meta property="article:publisher" content="https://www.facebook.com/FishDuckOnline"><meta property="article:published_time" content="2022-01-08T10:05:19+00:00"><meta property="article:modified_time" content="2022-01-08T18:25:32+00:00"><meta property="article:tag" content="Oregon NFL Draft"><meta name="twitter:domain" content="fishduck.com"><meta name="twitter:site" content="@fishduckdotcom"><meta name="twitter:title" content="Oregon&#039;s Most Successful NFL Draft Pick Players | FishDuck"><meta name="twitter:description" content="The Draft is one of the most important moments in the entire NFL calendar, as it allows teams the chance to scoop up some of the best talent from schools across..."><meta name="twitter:card" content="summary_large_image"><meta name="twitter:image" content="https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-300x300-cropped.jpg?p=193142"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="OregonReigns"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="5 minutes"><meta name="thumbnail" content="https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-600x315-cropped.jpg"> <script type=application/ld+json>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</script> <meta name="wpsso-end" content="wpsso meta tags and schema markup end"><meta name="wpsso-cached" content="2022-01-19T01:23:55+00:00"><meta name="wpsso-added" content="2022-01-19T01:23:55+00:00 in 0.170717 secs for fishduck.com"><style>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</style><link rel=icon href=https://cdn.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-32x32.png sizes=32x32><link rel=icon href=https://cdn.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-192x192.png sizes=192x192><link rel=apple-touch-icon href=https://cdn.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-180x180.png><meta name="msapplication-TileImage" content="https://cdn.fishduck.com/wp-content/uploads/2019/04/cropped-favicon-512-270x270.png"><style id=wp-custom-css>#spMainContainer #spAck{display:none}#wppb-submit,#recover_password,#edit_profile,#register{color:#000}</style><style id=x-generated-css>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</style><link rel=stylesheet href="//fonts.googleapis.com/css?family=Lato:400,400i,700,700i&#038;subset=latin,latin-ext&#038;display=auto" type=text/css media=all data-x-google-fonts></head><body class="post-template-default single single-post postid-193142 single-format-standard x-integrity x-integrity-light x-full-width-layout-active x-full-width-active pro-v4_2_3"><div id=x-root class=x-root ><div id=x-site class="x-site site" ><header class=x-masthead role=banner ><div class="e154983-1 x-bar x-bar-top x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xl x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154983-1&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;4em&quot;} ><div class="e154983-1 x-bar-content"><div class="e154983-2 x-bar-container" ><ul class="e154983-3 x-menu x-menu-inline  x-hide-xs x-menu-first-level" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154985" id=menu-item-154985 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154986" id=menu-item-154986 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154987" id=menu-item-154987 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154988" id=menu-item-154988 > <a class="e154983-3 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Contact href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul><div class="e154983-4 x-mod-container" > <a class="e154983-4 x-anchor x-anchor-toggle has-graphic has-particle" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-4 aria-controls=e154983-4-dropdown aria-expanded=false aria-haspopup=true aria-label="Toggle Dropdown Content" ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-s=&#xf002; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-b_c" aria-hidden=true > <span></span> </span> </a><div id=e154983-4-dropdown class="e154983-4 x-dropdown" data-x-stem data-x-stem-top data-x-toggleable=e154983-4 aria-hidden=true ><form class="e154983-4 x-search" data-x-search={&quot;search&quot;:true} action=https://fishduck.com/ method=get ><label class=visually-hidden for=s-e154983-4 >Search</label><input id=s-e154983-4 class=x-search-input type=search name=s value tabindex=0 placeholder=Search> <button class="x-search-btn x-search-btn-submit" type=button data-x-search-submit tabindex=0 ><span class=visually-hidden>Submit</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><circle fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 cx=10 cy=10 r=9 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=22 y1=22 x2=16.4 y2=16.4 stroke-linejoin=miter /></svg></button> <button class="x-search-btn x-search-btn-clear" type=button data-x-search-clear tabindex=0 ><span class=visually-hidden>Clear</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=5 x2=5 y2=19 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=19 x2=5 y2=5 stroke-linejoin=miter /></svg></button></form></div></div></div><div class="e154983-5 x-bar-container" > <a class="e154983-6 x-anchor x-anchor-toggle  x-hide-lg x-hide-md x-hide-sm x-hide-xl has-graphic" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-6 data-x-toggle-overlay=1 aria-controls=e154983-6-off-canvas aria-expanded=false aria-haspopup=true aria-label="Toggle Off Canvas Content" ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <span class="x-toggle x-toggle-grid x-graphic-child x-graphic-toggle" aria-hidden=true > <span class=x-toggle-grid-center data-x-toggle-anim=x-grid-1></span> </span> </span></div> </a></div></div></div><div class="e154983-7 x-bar-space x-bar-space-top x-bar-space-h" style="display: none;" ></div><div class="e154983-7 x-bar x-bar-top x-bar-h x-bar-relative x-bar-is-sticky" data-x-bar={&quot;id&quot;:&quot;e154983-7&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;75px&quot;,&quot;triggerOffset&quot;:&quot;0&quot;,&quot;shrink&quot;:&quot;0&quot;,&quot;scroll&quot;:true} ><div class="e154983-7 x-bar-scroll-outer" ><div class="e154983-7 x-bar-scroll-inner x-bar-outer-spacers" ><div class="e154983-7 x-bar-content"><div class="e154983-8 x-bar-container" > <a class="e154983-9 x-image x-image-preserve-ratio" style="height: 100%; max-height: 59.5px;" href=https://fishduck.com > <img src=https://cdn.fishduck.com/wp-content/uploads/2020/12/FishDuck-Community-Logo.png width=225 height=59.5 alt=FishDuck loading=lazy> </a></div><div class="e154983-10 x-bar-container" ><ul class="e154983-11 x-menu x-menu-inline  x-hide-lg x-hide-md x-hide-sm x-hide-xl x-hide-xs x-menu-first-level" ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-154990" id=menu-item-154990 > <a class="e154983-11 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Home href=https://fishduck.com ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Home</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154991" id=menu-item-154991 > <a class="e154983-11 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Analysis Library" href=https://fishduck.com/the-oregon-football-repository-by-fishduck-com/the-oregon-football-analysis-library-by-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Analysis Library</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154992" id=menu-item-154992 > <a class="e154983-11 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Football Repository" href=https://fishduck.com/2017/10/building-an-oregon-football-repository-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Football Repository</span></div></div> <span class="x-particle is-primary" data-x-particle="scale-x inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul> <a class="e154983-12 x-anchor x-anchor-toggle has-graphic" tabindex=0 data-x-toggle=1 data-x-toggleable=e154983-12 data-x-toggle-overlay=1 aria-controls=e154983-12-off-canvas aria-expanded=false aria-haspopup=true aria-label="Toggle Off Canvas Content" ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <span class="x-toggle x-toggle-grid x-graphic-child x-graphic-toggle" aria-hidden=true > <span class=x-toggle-grid-center data-x-toggle-anim=x-grid-1></span> </span> </span></div> </a></div></div></div></div></div><div class="e154983-13 x-bar x-bar-top x-bar-h x-bar-relative x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154983-13&quot;,&quot;region&quot;:&quot;top&quot;,&quot;height&quot;:&quot;50px&quot;} ><div class="e154983-13 x-bar-content"><div class="e154983-14 x-bar-container" ><div class="e154983-15 x-text" ><p style="text-align: center;"><span style="color: #ffcc00;"><a href=https://forum.fishduck.com style="color: #ffcc00;">Click Here To Enter The FishDuck Forum</a></span></p></div></div></div></div></header><div class="x-container max width offset"><div class="x-main full" role=main><article id=post-193142 class="post-193142 post type-post status-publish format-standard has-post-thumbnail hentry category-editorials tag-oregon-nfl-draft"><div class=entry-featured><div class=entry-thumb><img src=https://cdn.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter.jpg width=1200 height=630 class="attachment-entry-fullwidth size-entry-fullwidth wp-post-image" alt loading=lazy srcset="https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-467x245.jpg 467w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-762x400.jpg 762w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-768x403.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-100x53.jpg 100w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-600x315-cropped.jpg 600w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-800x420.jpg 800w" sizes="(max-width: 1200px) 100vw, 1200px" data-wp-pid=185575><noscript><img width=1200 height=630 src=https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter.jpg class="attachment-entry-fullwidth size-entry-fullwidth wp-post-image" alt loading=lazy srcset="https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-467x245.jpg 467w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-762x400.jpg 762w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-768x403.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-100x53.jpg 100w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-600x315-cropped.jpg 600w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-800x420.jpg 800w" sizes="(max-width: 1200px) 100vw, 1200px" data-wp-pid=185575></noscript></div></div><div class=entry-wrap><header class=entry-header><h1 class="entry-title">Oregon&#8217;s Most Successful NFL Draft Pick Players</h1><p class=p-meta><span><i class=x-icon-pencil data-x-icon-s=&#xf303;></i> OregonReigns</span><span><time class=entry-date datetime=2022-01-08T02:05:19-08:00><i class=x-icon-calendar data-x-icon-s=&#xf073;></i> January 8, 2022</time></span><span><a href=https://fishduck.com/category/editorials/ title="View all posts in: &ldquo;Editorials&rdquo;"><i class=x-icon-bookmark data-x-icon-s=&#xf02e;></i> Editorials</a></span></p></header><div class="entry-content content"><div class=wpsso-pinterest-pin-it-image style="display:none !important;"> <img src=https://cdn.fishduck.com/wp-content/uploads/2021/01/Haloti-Ngata_Twitter-800x420.jpg width=0 height=0 class=skip-lazy style=width:0;height:0; alt data-pin-description="The Draft is one of the most important moments in the entire NFL calendar, as it allows teams the chance to scoop up some of the best talent from schools across..."></div><div class="wpsso-rrssb wpsso-rrssb-content wpsso-rrssb-pos-top" id=wpsso-rrssb-content-post-193142><div class="wpsso-rrssb-limit wpsso-rrssb-content-limit" style="max-width:472px; margin:0 auto;"><ul class="rrssb-buttons en_US clearfix"> <li class=rrssb-facebook> <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ffishduck.com%2F2022%2F01%2Foregons-most-successful-nfl-draft-pick-players%2F" class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg preserveAspectRatio=xMidYMid width=29 height=29 viewBox="0 0 29 29"> <path d="M26.4 0H2.6C1.714 0 0 1.715 0 2.6v23.8c0 .884 1.715 2.6 2.6 2.6h12.393V17.988h-3.996v-3.98h3.997v-3.062c0-3.746 2.835-5.97 6.177-5.97 1.6 0 2.444.173 2.845.226v3.792H21.18c-1.817 0-2.156.9-2.156 2.168v2.847h5.045l-.66 3.978h-4.386V29H26.4c.884 0 2.6-1.716 2.6-2.6V2.6c0-.885-1.716-2.6-2.6-2.6z" class=cls-2 fill-rule=evenodd /> </svg> </span> <span class=rrssb-text>facebook</span> </a> </li><li class=rrssb-twitter> <a href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Ffishduck.com%2F2022%2F01%2Foregons-most-successful-nfl-draft-pick-players%2F&url=https%3A%2F%2Ffishduck.com%2F2022%2F01%2Foregons-most-successful-nfl-draft-pick-players%2F&text=Oregon%27s%20Most%20Successful%20NFL%20Draft%20Pick%20Players%20%7C%20FishDuck%20%23OregonNFLDraft&via=fishduckdotcom" class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M24.253 8.756C24.69 17.08 18.297 24.182 9.97 24.62c-3.122.162-6.22-.646-8.86-2.32 2.702.18 5.375-.648 7.507-2.32-2.072-.248-3.818-1.662-4.49-3.64.802.13 1.62.077 2.4-.154-2.482-.466-4.312-2.586-4.412-5.11.688.276 1.426.408 2.168.387-2.135-1.65-2.73-4.62-1.394-6.965C5.574 7.816 9.54 9.84 13.802 10.07c-.842-2.738.694-5.64 3.434-6.48 2.018-.624 4.212.043 5.546 1.682 1.186-.213 2.318-.662 3.33-1.317-.386 1.256-1.248 2.312-2.4 2.942 1.048-.106 2.07-.394 3.02-.85-.458 1.182-1.343 2.15-2.48 2.71z"/> </svg> </span> <span class=rrssb-text>twitter</span> </a> </li><li class=rrssb-reddit> <a href="http://www.reddit.com/submit?url=https%3A%2F%2Ffishduck.com%2F2022%2F01%2Foregons-most-successful-nfl-draft-pick-players%2F&title=Oregon%27s%20Most%20Successful%20NFL%20Draft%20Pick%20Players%20%7C%20FishDuck&text=The%20Draft%20is%20one%20of%20the%20most%20important%20moments%20in%20the%20entire%20NFL%20calendar%2C%20as%20it%20allows%20teams%20the%20chance%20to%20scoop%20up%20some%20of%20the%20best%20talent%20from%20schools%20across..."> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M11.794 15.316c0-1.03-.835-1.895-1.866-1.895-1.03 0-1.893.866-1.893 1.896s.863 1.9 1.9 1.9c1.023-.016 1.865-.916 1.865-1.9zM18.1 13.422c-1.03 0-1.895.864-1.895 1.895 0 1 .9 1.9 1.9 1.865 1.03 0 1.87-.836 1.87-1.865-.006-1.017-.875-1.917-1.875-1.895zM17.527 19.79c-.678.68-1.826 1.007-3.514 1.007h-.03c-1.686 0-2.834-.328-3.51-1.005-.264-.265-.693-.265-.958 0-.264.265-.264.7 0 1 .943.9 2.4 1.4 4.5 1.402.005 0 0 0 0 0 .005 0 0 0 0 0 2.066 0 3.527-.46 4.47-1.402.265-.264.265-.693.002-.958-.267-.334-.688-.334-.988-.043z"/> <path d="M27.707 13.267c0-1.785-1.453-3.237-3.236-3.237-.792 0-1.517.287-2.08.76-2.04-1.294-4.647-2.068-7.44-2.218l1.484-4.69 4.062.955c.07 1.4 1.3 2.6 2.7 2.555 1.488 0 2.695-1.208 2.695-2.695C25.88 3.2 24.7 2 23.2 2c-1.06 0-1.98.616-2.42 1.508l-4.633-1.09c-.344-.082-.693.117-.803.454l-1.793 5.7C10.55 8.6 7.7 9.4 5.6 10.75c-.594-.45-1.3-.75-2.1-.72-1.785 0-3.237 1.45-3.237 3.2 0 1.1.6 2.1 1.4 2.69-.04.27-.06.55-.06.83 0 2.3 1.3 4.4 3.7 5.9 2.298 1.5 5.3 2.3 8.6 2.325 3.227 0 6.27-.825 8.57-2.325 2.387-1.56 3.7-3.66 3.7-5.917 0-.26-.016-.514-.05-.768.965-.465 1.577-1.565 1.577-2.698zm-4.52-9.912c.74 0 1.3.6 1.3 1.3 0 .738-.6 1.34-1.34 1.34s-1.343-.602-1.343-1.34c.04-.655.596-1.255 1.396-1.3zM1.646 13.3c0-1.038.845-1.882 1.883-1.882.31 0 .6.1.9.21-1.05.867-1.813 1.86-2.26 2.9-.338-.328-.57-.728-.57-1.26zm20.126 8.27c-2.082 1.357-4.863 2.105-7.83 2.105-2.968 0-5.748-.748-7.83-2.105-1.99-1.3-3.087-3-3.087-4.782 0-1.784 1.097-3.484 3.088-4.784 2.08-1.358 4.86-2.106 7.828-2.106 2.967 0 5.7.7 7.8 2.106 1.99 1.3 3.1 3 3.1 4.784C24.86 18.6 23.8 20.3 21.8 21.57zm4.014-6.97c-.432-1.084-1.19-2.095-2.244-2.977.273-.156.59-.245.928-.245 1.036 0 1.9.8 1.9 1.9-.016.522-.27 1.022-.57 1.327z"/> </svg> </span> <span class=rrssb-text>reddit</span> </a> </li><li class=rrssb-linkedin> <a href="http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Ffishduck.com%2F2022%2F01%2Foregons-most-successful-nfl-draft-pick-players%2F&title=Oregon%27s%20Most%20Successful%20NFL%20Draft%20Pick%20Players%20%7C%20FishDuck&summary=The%20Draft%20is%20one%20of%20the%20most%20important%20moments%20in%20the%20entire%20NFL%20calendar%2C%20as%20it%20allows%20teams%20the%20chance%20to%20scoop%20up%20some%20of%20the%20best%20talent%20from%20schools%20across..." class=popup> <span class=rrssb-icon> <svg xmlns=http://www.w3.org/2000/svg width=28 height=28 viewBox="0 0 28 28"> <path d="M25.424 15.887v8.447h-4.896v-7.882c0-1.98-.71-3.33-2.48-3.33-1.354 0-2.158.91-2.514 1.802-.13.315-.162.753-.162 1.194v8.216h-4.9s.067-13.35 0-14.73h4.9v2.087c-.01.017-.023.033-.033.05h.032v-.05c.65-1.002 1.812-2.435 4.414-2.435 3.222 0 5.638 2.106 5.638 6.632zM5.348 2.5c-1.676 0-2.772 1.093-2.772 2.54 0 1.42 1.066 2.538 2.717 2.546h.032c1.71 0 2.77-1.132 2.77-2.546C8.056 3.593 7.02 2.5 5.344 2.5h.005zm-2.48 21.834h4.896V9.604H2.867v14.73z"/> </svg> </span> <span class=rrssb-text>linkedin</span> </a> </li></ul></div></div><div class=pf-content><p>The Draft is one of the most important moments in the entire <span style="text-decoration: underline;"><a href=https://www.nfl.com/schedules/ target=_blank rel=noopener><em><strong>NFL calendar</strong></em></a></span>, as it allows teams the chance to scoop up some of the best talent from schools across the US.</p><p>The next NFL Draft is only a few months away, taking place between the 28th and 30th of April, and there are plenty of prospects who look ripe for the picking. If you fancy your chances, you can even <span style="text-decoration: underline;"><a href=https://www.888sport.com/ target=_blank rel=noopener><em><strong>bet</strong></em></a></span> on who will be selected in the 2022 NFL Draft.</p><p>Oregon has long been one of the most successful schools when it comes to producing Draft picks, with many Ducks players going on to have stellar careers in the NFL. Here are some of the most prolific.</p><div id=attachment_171906 class="wp-caption aligncenter" style="width: 1200px"><img src=https://cdn.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video.jpg loading=lazy class="size-full wp-image-171906" alt width=1200 height=600 data-wp-pid=171906 srcset="https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-490x245.jpg 490w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-768x384.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-800x400.jpg 800w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-100x50.jpg 100w" sizes="(max-width: 1200px) 100vw, 1200px"><noscript><img loading=lazy class="size-full wp-image-171906" src=https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video.jpg alt width=1200 height=600 data-wp-pid=171906 srcset="https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-490x245.jpg 490w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-768x384.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-800x400.jpg 800w, https://cdn.fishduck.com/wp-content/uploads/2020/12/Haloti-Ngata_Video-100x50.jpg 100w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript><p class=attr-credit-text>From Video</p><p class=wp-caption-text>Haloti Ngata was dominant&#8230;</p></div><h4><span style="text-decoration: underline;"><em><strong>Haloti Ngata</strong></em></span></h4><p>The hulking defensive tackle was the <strong>No. 12 overall pick</strong> in the 2006 Draft, selected by the Baltimore Ravens &#8211; the first time in the franchise&#8217;s history that they selected a defensive lineman in the first round of the Draft.&#160;Right off the bat from his rookie season, Ngata was a starter for the Ravens and remained so for his nine seasons with the team. From 2009-13, he was selected for <strong>five Pro Bowls in a row.</strong></p><p>He won the big one with the Ravens at the 2012 Super Bowl, and overall Ngata proved himself one of the most dominant defensive players in the league during his career, which ended in 2019.</p><h4><span style="text-decoration: underline;"><em><strong>Kyle Long</strong></em></span></h4><p>Coming from a family steeped in football history, it was no real surprise that Long rose to prominence with the Ducks. The offensive lineman was a <strong>first-round pick</strong> in the 2013 Draft and went to the Chicago Bears, where he hit the ground running.</p><p>In each of his first three seasons at the franchise he was selected for the Pro Bowl. Injuries plagued the last few years of his career, and he announced his retirement in 2020, before returning to the fold with the Kansas City Chiefs in 2021.</p><div id=attachment_193151 class="wp-caption aligncenter" style="width: 1200px"><img src=https://cdn.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson.jpg loading=lazy class="size-full wp-image-193151" alt width=1200 height=630 data-wp-pid=193151 srcset="https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-467x245.jpg 467w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-762x400.jpg 762w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-768x403.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-100x53.jpg 100w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-600x315.jpg 600w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-800x420.jpg 800w" sizes="(max-width: 1200px) 100vw, 1200px"><noscript><img loading=lazy class="size-full wp-image-193151" src=https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson.jpg alt width=1200 height=630 data-wp-pid=193151 srcset="https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-467x245.jpg 467w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-762x400.jpg 762w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-768x403.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-100x53.jpg 100w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-600x315.jpg 600w, https://cdn.fishduck.com/wp-content/uploads/2022/01/Max-Unger-Jonathan-Stewart-and-Dennis-Dixon_Bob-Wilson-800x420.jpg 800w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript><p class=attr-credit-text>Bob Wilson</p><p class=wp-caption-text>Max Unger, (No. 60) Jonathan Stewart and Dennis Dixon.</p></div><h4><em><strong><span style="text-decoration: underline;">Max Unger</span></strong></em></h4><p>In 2009, <span style="text-decoration: underline;"><a href=https://goducks.com/ target=_blank rel=noopener><em><strong>the Ducks</strong></em></a></span> had three second round picks in the NFL Draft, one of which was Unger, who was picked 49th overall. He immediately made his mark on the league, starting at right guard for the Seattle Seahawks before moving to center.</p><p>He was selected for consecutive <strong>Pro Bowls</strong> in 2012 and 2013 and ended up <strong>winning Super Bowl XLVIII with the Seahawks</strong>. He moved to the New Orleans Saints in 2015 and in 2018 &#8211; his final season as a player &#8211; was once again chosen for the Pro Bowl.</p><h4><span style="text-decoration: underline;"><em><strong>Russ Francis</strong></em></span></h4><p>Originally drafted by the New England Patriots in 1975, tight end Francis achieved enormous success with two franchises. With the Patriots, Francis became a <strong>Pro Bowl selection every season</strong> between 1977 and 1979. He played his first eight seasons in New England, gaining more than 500 yards receiving in most of those campaigns.</p><p>He then moved to the 49ers, where he eventually<strong> won the Super Bowl in 1985</strong>. In total, Francis played a whopping 14 seasons in the NFL and finished with 393 career receptions, 5,262 yards and 40 touchdowns.</p><h4><span style="text-decoration: underline;"><em><strong>Jairus Byrd</strong></em></span></h4><p>Byrd entered the 2009 Draft as an underclassman and was selected by the Bills in the second round. He impressed as a rookie, tying as a defensive back for the NFL lead and even setting a franchise rookie record for interceptions.</p><p>In his last two seasons with the Bills, 2012 and 2013, Byrd was selected for <strong>the Pro Bowl</strong> before eventually moving to the New Orleans Saints. His career there was hampered by injury, and he finished his career with the Carolina Panthers.</p><div id=attachment_185576 class="wp-caption aligncenter" style="width: 1200px"><img src=https://cdn.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter.jpg loading=lazy class="size-full wp-image-185576" alt width=1200 height=630 data-wp-pid=185576 srcset="https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-467x245.jpg 467w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-762x400.jpg 762w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-768x403.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-100x53.jpg 100w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-600x315-cropped.jpg 600w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-800x420.jpg 800w" sizes="(max-width: 1200px) 100vw, 1200px"><noscript><img loading=lazy class="size-full wp-image-185576" src=https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter.jpg alt width=1200 height=630 data-wp-pid=185576 srcset="https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter.jpg 1200w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-467x245.jpg 467w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-762x400.jpg 762w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-768x403.jpg 768w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-100x53.jpg 100w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-600x315-cropped.jpg 600w, https://cdn.fishduck.com/wp-content/uploads/2021/01/Jonathan-Stewart_Twitter-800x420.jpg 800w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript><p class=attr-credit-text>Twitter</p><p class=wp-caption-text>Jonathan Stewart played a long career for Carolina.</p></div><h4><span style="text-decoration: underline;"><em><strong>Jonathan Stewart</strong></em></span></h4><p>As a<strong> two-time All-American</strong> at Oregon, the running back was primed and ready for the NFL by the time he was drafted in 2008 by the Panthers. In his first two seasons in Carolina, he achieved 10 touchdowns and in that second season he made 1,133 rushing yards, which would end up being a career best.</p><p>He finished five of his 10 seasons with the Panthers with at least 800 rushing yards before finishing his career at the New York Giants. His progression as a player was hindered by injuries &#8211; and a job-share at the Panthers &#8211; but Stewart still left his mark.</p><h4><span style="text-decoration: underline;"><em><strong>2022 Draft picks</strong></em></span></h4><p>Defensive end <strong>Kayvon Thibodeaux</strong> could well be the first overall pick in the <span style="text-decoration: underline;"><a href=https://www.si.com/nfl/draft/nfl-draft/top-five-oregon-prospects-in-2022-nfl-draft target=_blank rel=noopener><em><strong>2022 Draft</strong></em></a></span> and he&#8217;s tipped to be a future star of the NFL. Expect <strong>Verone McKinley III</strong> to also be selected in the first round; the defensive back has proven himself one of the smartest players on the Oregon roster.</p><p>The Ducks have supplied the NFL with some excellent players over the years, from Super Bowl winners to regular Pro Bowl selections. Looking at the potential pool of Oregon players for the 2022 Draft, that trend looks set to continue.</p><p><strong>OregonReigns</strong><br> Lakeside, Oregon<br> <em>Top Photo by <strong>Baltimore Ravens Twitter</strong></em></p><div class="printfriendly pf-button pf-button-content pf-alignright"><a href=# rel=nofollow onClick="window.print(); return false;" title="Printer Friendly, PDF & Email"><img src=https://cdn.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif data-lazy-src=https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png class=pf-button-img alt="Print Friendly, PDF &amp; Email" style="width: 112px;height: 24px;"><noscript><img class=pf-button-img src=https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png alt="Print Friendly, PDF & Email" style="width: 112px;height: 24px;"></noscript></a></div></div><div class=relpost-thumb-wrapper><div class=relpost-thumb-container><h3>Related Articles:</h3><div style="clear: both"></div><div style="clear: both"></div><div class=relpost-block-container><a class=relpost-block-single href=https://fishduck.com/2022/01/its-time-to-kill-the-early-signing-period/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="It's Time to Kill the Early Signing Period"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2022/01/Issah-Crocker-v-Oklahoma-2021-Alamo-Bowl-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">It's Time to Kill the Early Signing Period</div></div></a><a class=relpost-block-single href=https://fishduck.com/2022/01/the-lanning-effect-best-off-season-for-oregon-fans-yet/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="The Lanning Effect: Best Off-Season for Oregon Fans Yet?"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2022/01/Lanning_CBS-Sports-Video-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">The Lanning Effect: Best Off-Season for Oregon Fans Yet?</div></div></a><a class=relpost-block-single href=https://fishduck.com/2022/01/how-dan-lanning-and-lincoln-riley-can-balance-college-football/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="How Dan Lanning and Lincoln Riley Can Balance College Football"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2022/01/USC-vs-Oregon_FP_John-McGillen-USC-Athletics_FO-150x150.png) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">How Dan Lanning and Lincoln Riley Can Balance College Football</div></div></a><a class=relpost-block-single href=https://fishduck.com/2022/01/a-super-fast-way-too-early-prediction-for-2022/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="A Super Fast, Way Too Early Prediction for 2022"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2022/01/ekTC4QqE-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">A Super Fast, Way Too Early Prediction for 2022</div></div></a><a class=relpost-block-single href=https://fishduck.com/2022/01/national-championship-gameday-thread-watch-for-georgia-blitzes/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="National Championship GameDay Thread: Watch for Georgia Blitzes!"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2022/01/Georgia-Rain-Blitz_Coordinator-Project-Video-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">National Championship GameDay Thread: Watch for Georgia Blitzes!</div></div></a><a class=relpost-block-single href=https://fishduck.com/2022/01/oregon-fans-bid-farewell-to-a-class-act-mustache/ ><div class=relpost-custom-block-single style="width: 150px; height: 225px;"><div class=relpost-block-single-image alt="Aaron Feld"  style="background: transparent url(https://cdn.fishduck.com/wp-content/uploads/2022/01/FELDREAL-e1641711286847-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class=relpost-block-single-text  style="font-family: Arial;  font-size: 12px;  color: #333333;">Oregon Fans Bid Farewell to a Class Act Mustache</div></div></a></div><div style="clear: both"></div></div></div><div class=saboxplugin-wrap itemtype=http://schema.org/Person itemscope itemprop=author><div class=saboxplugin-tab><div class=saboxplugin-gravatar><img src=https://cdn.fishduck.com/wp-content/plugins/lazy-load/images/1x1.trans.gif data-lazy-src=https://cdn.fishduck.com/wp-content/uploads/2021/04/Wet-Helmet_Kevin-Cline.jpg width=100 height=100 alt itemprop=image><noscript><img src=https://cdn.fishduck.com/wp-content/uploads/2021/04/Wet-Helmet_Kevin-Cline.jpg width=100  height=100 alt itemprop=image></noscript></div><div class=saboxplugin-authorname><a href=https://fishduck.com/author/oregonreigns/ class="vcard author" rel=author itemprop=url><span class=fn itemprop=name>OregonReigns</span></a></div><div class=saboxplugin-desc><div itemprop=description><p>OregonReigns is an occasional contributor to FishDuck and loves his Ducks!</p></div></div><div class=clearfix></div></div></div><div class=awac-wrapper><div class="awac widget text-88"><h4 class="widget-title">FishDuck Has New Off-Season Schedule and see the OUR BELOVED DUCKS Forum!</h4><div class=textwidget><p><strong>FishDuck articles </strong>will now be on <em>Monday-Tuesday-Wednesday</em> <strong>only</strong> during the off-season, and then we will go back to seven days a week during the football season beginning in August.</p><p>We will have some occasional guest articles later in the week, but the <em><strong>hottest</strong></em> Oregon football information will be posted in the<strong><em> OBD</em> forum</strong>!</p><p>The <strong><span style="text-decoration: underline;"><a href=https://forum.fishduck.com/ target=_blank rel=noopener><em>Our Beloved Ducks</em></a></span> Forum</strong> <em>(OBD)</em> is where we we discuss the article above and many more topics, as it is so much easier in a message board format over there.  At <em><strong>the <span style="text-decoration: underline;">free</span> OBD forum</strong></em> we will be posting <strong>Oregon Sports article links</strong>, the daily <strong>Press Releases</strong> from the Athletic Department and <em><strong>the news</strong></em> coming out every day.</p><p>Be a part of the forum and stay caught up!  When you wish to post there, do know that you are protected just as you were on <em><strong>FishDuck</strong></em>. Join us on the free forum<span style="text-decoration: underline;"> <a href=https://forum.fishduck.com/ target=_blank rel=noopener><em><strong>right here!</strong></em></a></span></p><p><a href=https://fishduck.com/posting-rules/ target=_blank rel=noopener><span style="text-decoration: underline;"><strong><em>Our 33 rules</em></strong></span> </a>at the free <em><strong>OBD Forum</strong></em> can be summarized to this: 1) <strong>be polite and respectful</strong>, 2) <strong>keep it clean</strong>, and 3) <strong>no reference of <em>any</em> kind to politics.</strong> <em>Easy-peasy!</em></p><p><em><strong>OBD Forum</strong></em> members&#8230;.we got your back.  <em><strong>No Trolls Allowed!</strong></em></p></div></div></div></div></div><footer class="entry-footer cf"> <a href=https://fishduck.com/tag/oregon-nfl-draft/ rel=tag>Oregon NFL Draft</a></footer></article></div></div><footer class=x-colophon role=contentinfo ><div class="e154993-1 x-bar x-bar-footer x-bar-h x-bar-relative  x-hide-lg x-hide-md x-hide-sm x-hide-xs x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154993-1&quot;,&quot;region&quot;:&quot;footer&quot;,&quot;height&quot;:&quot;auto&quot;} ><div class="e154993-1 x-bar-content"><div class="e154993-2 x-bar-container" > <a class="e154993-3 x-image" href=https://fishduck.com > <img src=https://cdn.fishduck.com/wp-content/uploads/2020/12/FishDuck-Community-Logo.png width=225 height=59.5 alt="Fish Duck" loading=lazy> </a></div><div class="e154993-4 x-bar-container" > <a class="e154993-5 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=https://www.facebook.com/FishDuckOnline/ ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf09a; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-6 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=https://twitter.com/fishduckdotcom ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf099; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-7 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=https://www.youtube.com/user/FishDuck83 ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf167; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a></div><div class="e154993-8 x-bar-container" ><ul class="e154993-9 x-menu x-menu-inline x-menu-first-level" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154994" id=menu-item-154994 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184839" id=menu-item-184839 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://forum.fishduck.com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Our Beloved Ducks Forum</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154995" id=menu-item-154995 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Commenting Rules" href=https://fishduck.com/commenting-rules/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Posting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154996" id=menu-item-154996 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154997" id=menu-item-154997 > <a class="e154993-9 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul></div><div class="e154993-10 x-bar-container" ><form class="e154993-11 x-search" data-x-search={&quot;search&quot;:true} action=https://fishduck.com/ method=get ><label class=visually-hidden for=s-e154993-11 >Search</label><input id=s-e154993-11 class=x-search-input type=search name=s value tabindex=0 placeholder=Search> <button class="x-search-btn x-search-btn-submit" type=button data-x-search-submit tabindex=0 ><span class=visually-hidden>Submit</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><circle fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 cx=10 cy=10 r=9 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=22 y1=22 x2=16.4 y2=16.4 stroke-linejoin=miter /></svg></button> <button class="x-search-btn x-search-btn-clear" type=button data-x-search-clear tabindex=0 ><span class=visually-hidden>Clear</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=5 x2=5 y2=19 stroke-linejoin=miter /><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=19 x2=5 y2=5 stroke-linejoin=miter /></svg></button></form></div></div></div><div class="e154993-12 x-bar x-bar-footer x-bar-h x-bar-relative  x-hide-xl x-bar-outer-spacers" data-x-bar={&quot;id&quot;:&quot;e154993-12&quot;,&quot;region&quot;:&quot;footer&quot;,&quot;height&quot;:&quot;auto&quot;} ><div class="e154993-12 x-bar-content"><div class="e154993-13 x-bar-container" > <span class="e154993-14 x-image" > <img src=https://cdn.fishduck.com/wp-content/uploads/2019/04/FishDuck_Logo.png width=231.5 height=40 alt=Image loading=lazy> </span></div><div class="e154993-15 x-bar-container" > <a class="e154993-16 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf09a; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-17 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf099; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a><a class="e154993-18 x-anchor x-anchor-button has-graphic has-particle" tabindex=0 href=# ><div class=x-anchor-content> <span class=x-graphic aria-hidden=true > <i class="x-icon x-graphic-child x-graphic-icon x-graphic-primary" aria-hidden=true data-x-icon-b=&#xf167; ></i></span></div> <span class="x-particle is-primary" data-x-particle="scale-x_y inside-c_c" aria-hidden=true > <span></span> </span> </a></div><div class="e154993-19 x-bar-container" ><ul class="e154993-20 x-menu x-menu-inline x-menu-first-level" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154994" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184839" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://forum.fishduck.com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Our Beloved Ducks Forum</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154995" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 title="Commenting Rules" href=https://fishduck.com/commenting-rules/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Posting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154996" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154997" > <a class="e154993-20 x-anchor x-anchor-menu-item has-particle" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> <span class="x-particle is-primary" data-x-particle="scale-y inside-t_c" aria-hidden=true > <span></span> </span> </a> </li></ul></div><div class="e154993-21 x-bar-container" ><form class="e154993-22 x-search" data-x-search={&quot;search&quot;:true} action=https://fishduck.com/ method=get ><label class=visually-hidden for=s-e154993-22 >Search</label><input id=s-e154993-22 class=x-search-input type=search name=s value tabindex=0 placeholder=Search> <button class="x-search-btn x-search-btn-submit" type=button data-x-search-submit tabindex=0 ><span class=visually-hidden>Submit</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><circle fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 cx=10 cy=10 r=9 stroke-linejoin=miter /><line fill=none stroke-width=2 stroke-linecap=square stroke-miterlimit=10 x1=22 y1=22 x2=16.4 y2=16.4 stroke-linejoin=miter /></svg></button> <button class="x-search-btn x-search-btn-clear" type=button data-x-search-clear tabindex=0 ><span class=visually-hidden>Clear</span><svg xmlns=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink x=0px y=0px viewBox="-1 -1 25 25"><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=5 x2=5 y2=19 stroke-linejoin=miter /><line fill=none stroke-width=3 stroke-linecap=square stroke-miterlimit=10 x1=19 y1=19 x2=5 y2=5 stroke-linejoin=miter /></svg></button></form></div></div></div></footer><div id=e154983-6-off-canvas class="e154983-6 x-off-canvas x-off-canvas-right  x-hide-lg x-hide-md x-hide-sm x-hide-xl" role=dialog tabindex=-1 data-x-toggleable=e154983-6 aria-hidden=true aria-label="Off Canvas" ><span class=x-off-canvas-bg></span><button class="x-off-canvas-close x-off-canvas-close-right" data-x-toggle-close=1 aria-label="Close Off Canvas Content" > <span>&times;</span> </button><div class="x-off-canvas-content x-off-canvas-content-right" data-x-scrollbar={&quot;suppressScrollX&quot;:true} role=document aria-label="Off Canvas Content" ><ul class="e154983-6 x-menu x-menu-collapsed" ><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154985" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=About href=https://fishduck.com/about/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154986" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title="Commenting Rules" href=https://fishduck.com/2014/10/civility-is-required-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Commenting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154987" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=Volunteer href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154988" > <a class="e154983-6 x-anchor x-anchor-menu-item" tabindex=0 title=Contact href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li></ul></div></div><div id=e154983-12-off-canvas class="e154983-12 x-off-canvas x-off-canvas-right" role=dialog tabindex=-1 data-x-toggleable=e154983-12 aria-hidden=true aria-label="Off Canvas" ><span class=x-off-canvas-bg></span><button class="x-off-canvas-close x-off-canvas-close-right" data-x-toggle-close=1 aria-label="Close Off Canvas Content" > <span>&times;</span> </button><div class="x-off-canvas-content x-off-canvas-content-right" data-x-scrollbar={&quot;suppressScrollX&quot;:true} role=document aria-label="Off Canvas Content" ><ul class="e154983-12 x-menu x-menu-collapsed" ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-178454" id=menu-item-178454 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Home</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-190977" id=menu-item-190977 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://forum.fishduck.com/ id=x-menu-collapsed-anchor-e154983-12-0 data-x-toggle=collapse data-x-toggleable=e154983-12-0 aria-controls=x-menu-collapsed-list-e154983-12-0 aria-expanded=false aria-haspopup=true aria-label="Toggle Collapsed Sub Menu" ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Our Beloved Duck forum</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a><ul class="sub-menu x-collapsed" id=x-menu-collapsed-list-e154983-12-0 aria-hidden=true aria-labelledby=x-menu-collapsed-anchor-e154983-12-0 data-x-toggleable=e154983-12-0 data-x-toggle-collapse=1 ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178451" id=menu-item-178451 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/posting-rules/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Posting Rules</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178452" id=menu-item-178452 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/join-fishduck-com-main-page/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Volunteer</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178453" id=menu-item-178453 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/contact-fishduck/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Contact</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-178450" id=menu-item-178450 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/what-is-fishduck-com/ id=x-menu-collapsed-anchor-e154983-12-1 data-x-toggle=collapse data-x-toggleable=e154983-12-1 aria-controls=x-menu-collapsed-list-e154983-12-1 aria-expanded=false aria-haspopup=true aria-label="Toggle Collapsed Sub Menu" ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >About</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a><ul class="sub-menu x-collapsed" id=x-menu-collapsed-list-e154983-12-1 aria-hidden=true aria-labelledby=x-menu-collapsed-anchor-e154983-12-1 data-x-toggleable=e154983-12-1 data-x-toggle-collapse=1 ><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-191147" id=menu-item-191147 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/what-is-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >What is FishDuck?</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184103" id=menu-item-184103 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/terms-of-service/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Terms of Service</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184102" id=menu-item-184102 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/privacy-policy/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Privacy Policy</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178455" id=menu-item-178455 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/the-oregon-football-repository-by-fishduck-com/the-oregon-football-analysis-library-by-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Analysis Library</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178456" id=menu-item-178456 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/2017/10/building-an-oregon-football-repository-at-fishduck-com/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Football Repository</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-178457" id=menu-item-178457 > <a class="e154983-12 x-anchor x-anchor-menu-item" tabindex=0 href=https://fishduck.com/join-fishduck-com-main-page/student-internship-opportunities-at-fishduck-com/sports-reporter-internship/ ><div class=x-anchor-content><div class=x-anchor-text><span class=x-anchor-text-primary >Top Photo Credit</span></div>  <i class=x-anchor-sub-indicator data-x-skip-scroll=true aria-hidden=true data-x-icon-s=&#xf107; ></i></div> </a> </li></ul></div></div></div> <a class="x-scroll-top right fade" title="Back to Top"> <i class=x-icon-angle-up data-x-icon-s=&#xf106;></i> </a> <script>jQuery(document).ready(function($){var $window=$(window);var body=$('body');var bodyOffsetBottom=$window.scrollBottom();var bodyHeightAdjustment=body.height()-bodyOffsetBottom;var bodyHeightAdjusted=body.height()-bodyHeightAdjustment;var $scrollTopAnchor=$('.x-scroll-top');function sizingUpdate(){var bodyOffsetTop=$window.scrollTop();if(bodyOffsetTop>(bodyHeightAdjusted*0.75)){$scrollTopAnchor.addClass('in');}else{$scrollTopAnchor.removeClass('in');}}$window.on('scroll',sizingUpdate).resize(sizingUpdate);sizingUpdate();$scrollTopAnchor.on('click',function(){$('html, body').animate({scrollTop:0},850,'xEaseInOutExpo');return false;});});</script> </div>  <script id=pf_script>var pfHeaderImgUrl='';var pfHeaderTagline='';var pfdisableClickToDel='0';var pfImagesSize='full-size';var pfImageDisplayStyle='right';var pfEncodeImages='0';var pfShowHiddenContent='0';var pfDisableEmail='0';var pfDisablePDF='0';var pfDisablePrint='0';var pfCustomCSS='';var pfPlatform='WordPress';</script> <script async src=https://cdn.printfriendly.com/printfriendly.js></script> <script src=https://cdn.fishduck.com/wp-content/cache/minify/feab2.js></script> </body></html>